Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4588 closed Enhancement (fixed)

Manual selection of gtk version at configure time

Reported by: moben Owned by: jordan
Priority: Normal Milestone: 2.50
Component: GTK+ Client Version: 2.42
Severity: Normal Keywords: backport-2.4x gtk3 gtk
Cc:

Description

Some people/distributions might want to explicitly choose the gtk version to build against at configure time. This patch allows passing either '2' or '3' to --with-gtk Only the supplied version is then checked for and built against. If no version is specified the automagic kicks in like before

Attachments (1)

transmission-choose_gtk_version.patch (1.4 KB) - added by moben 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by moben

comment:1 Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.50
  • Resolution set to fixed
  • Status changed from new to closed

This is a good idea, but I think the patch needs some tweaking: if --with-gtk is omitted altogether, the GTK+ client isn't built. The default should be to build the GTK+ client if the GTK+ dev packages are installed.

I think r13031 does what you're suggesting.

comment:2 Changed 10 years ago by jordan

  • Keywords backport-2.4x added
Note: See TracTickets for help on using tickets.