Opened 11 years ago

Closed 11 years ago

#4590 closed Bug (invalid)

2.42 does not compile on Snow Leopard or earlier

Reported by: ryandesign Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.42
Severity: Normal Keywords:
Cc:

Description

transmission 2.42 cannot be compiled on Snow Leopard or earlier because of error "cannot find protocol declaration for 'NSPopoverDelegate'" (NSPopoverDelegate was introduced in Lion):

https://trac.macports.org/ticket/31731

Just like transmission 2.22 couldn't be compiled on Leopard or earlier because of error "cannot find protocol declaration for 'NSNetServiceDelegate'" (NSNetServiceDelegate was introduced in Snow Leopard):

https://trac.macports.org/ticket/29398

The readme does not state the minimum supported version of OS X. We at MacPorts need to understand whether you intend to support OS X versions earlier than Lion (in which case #29398 at least has a patch attached that might work), or not (in which case you should indicate that in the readme, and we will need to disable users' attempts to install this port on earlier OS X versions). Thanks.

Change History (1)

comment:1 Changed 11 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Transmission almost always requires the most current version of the operating system and dev kit to build. This is documented on https://trac.transmissionbt.com/wiki/Building. The minimum supported OS to run 2.42 is 10.5; 2.5 will require 10.6.

Note: See TracTickets for help on using tickets.