Opened 10 years ago

Closed 10 years ago

#4594 closed Bug (fixed)

[transmission-remote] corrupted (non-Unicode) string instead of status

Reported by: Link Mauve Owned by: jordan
Priority: Low Milestone: 2.50
Component: Transmission Version: 2.42
Severity: Normal Keywords: backport-2.4x
Cc:

Description

Each time I launch transmission-remote -l, a random string of three bytes starting with “y” replaces the status in each line.

It is reproducible on multiple computers, with transmission-remote and transmission-daemon version 2.42 or trunk.

Change History (3)

comment:1 Changed 10 years ago by geirha

I've investigated this issue a bit and found that this is caused by r12607 changing the values in the tr_torrent_activity enum (in libtransmission/transmission.h). It makes transmission-remote incompatible with pre r12607 transmission clients.

Last edited 10 years ago by geirha (previous) (diff)

comment:2 Changed 10 years ago by jordan

  • Keywords backport-2.4x added
  • Owner set to jordan
  • Status changed from new to assigned
  • Version changed from 2.42+ to 2.42

comment:3 Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.50
  • Resolution set to fixed
  • Status changed from assigned to closed

geirha, thanks for doing research on this.

in r13033 I've added code to give a more reasonable fallback status string, but IMO the real solution here is to not mix-and-match Transmission daemon and client versions.

Note: See TracTickets for help on using tickets.