Opened 11 years ago

Closed 11 years ago

#4615 closed Enhancement (duplicate)

Sort Torrents by Date Completed

Reported by: Renara Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.42
Severity: Normal Keywords:
Cc:

Description

Since torrents have a Date Completed value (in the Inspector, Activity tab, under Dates), I think it might be nice to be able to sort by this field.

It would probably have to sort by the date field first, then by progress. So in Descending direction you'd have the most recently complete torrents, followed by the torrent closest to completion (percent downloaded).

Would be handy! Not sure about seeding though, does it use the same date field? I don't know as I seed torrents indefinitely and just prune them manually now and then.

I suppose if seeding counts too, then it could be two options, sort by Date Downloaded, and Date Seeded? Date Downloaded would be data completed (download) then download progress, while Date Seeded would be date finished seeding, then ratio (then download progress).

If that's too complex though, then I think the Date Completed field as it's currently presented, followed by download progress, is a nice easy way, and useful, since it means all your finished torrents will jump to the top of the list to be removed, copied to a new location or whatever.

Change History (2)

comment:1 Changed 11 years ago by jordan

What is the use case for this feature?

comment:2 Changed 11 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a duplicate of ticket #3016

Note: See TracTickets for help on using tickets.