Opened 10 years ago

Closed 9 years ago

#4624 closed Bug (fixed)

Inconsistent behavior when clicking on items at the torrent list

Reported by: dirleyrls Owned by: jordan
Priority: Normal Milestone: 2.70
Component: Qt Client Version: 2.31
Severity: Normal Keywords: properties window
Cc: dirleyrls, lucke@…

Description

Currently, on all transmission-qt versions i've used [2.31+] under Kubuntu [10.04+], when you left-click an item from the torrent list, the Properties window shows up. At least for me, this is not the expected behavior. I think that the right behavior is to, when clicked, the item just get selected. This is how it works on transmission-gtk and how most item-listing UIs works out there.

Steps to reproduce the problem:

  1. Run transmission's qt client
  2. If there are no torrents in the list, add a couple
  3. Try to select some items by clicking at them
  4. Be forced to close the properties windows that shows up

Proposed solution

I'm providing a patch that removes the listener attached to the "item activated" signal from the torrent list view. This small change should be enough to fix this weird behavior.

Attachments (2)

patch-remove-item-activated-listener.diff (662 bytes) - added by dirleyrls 10 years ago.
A small patch that removes the listener attached to the "item activated" signal of the torrent lis items
patch-proxy-activate-item-on-single-click.diff (1.7 KB) - added by dirleyrls 9 years ago.

Download all attachments as: .zip

Change History (15)

Changed 10 years ago by dirleyrls

A small patch that removes the listener attached to the "item activated" signal of the torrent lis items

comment:1 Changed 10 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

...but then double-clicking a row no longer pops up the properties dialog.

The problem isn't that we're listening for the "activated" signal, but that your system is triggering that signal when there's a single right-click. This issue doesn't happen in Ubuntu, Mint, or Fedora, which follow a "single click selects" model.

You can tweak your system settings to customize your click preference this way:

http://askubuntu.com/questions/14048/how-to-disable-single-mouse-click-folder-opening

comment:2 Changed 9 years ago by lucke

Can't it be done in such a way that single-clicking selects the entry in the main window and double-clicking opens the window with its properties? The current behaviour of qtr with "single-click opens files and folders" option set is annoying and arguably not logical.

I dislike having to click on folder/file icons twice if I want to open them, so my KDE is set to the "single-click opens files and folders" option. I don't know of any other place in KDE where this setting matters, except in Dolphin and KFileChooser (it changes the behaviour in the icon view of systemsettings, but there, selecting an icon doesn't seem to offer the user anything, except allowing to navigate to neighbouring icons with keyboard, which is of dubious use). In Dolphin and KFileChooser, I can select the icon(s) by holding Ctrl. Additionally, in Dolphin I can also select icons by using the + located in the highlighted icon's corner - and just hovering over the icon updates the interface to show its details.

Contrasting it with qtr: I can't select entries (torrents) in the main window by single-clicking - I can only right-click or open the properties window and close it. Ctrl in the single-click mode still makes the properties window pop up, stealing focus. Thus I can't select files with mouse and delete them with Del or Shift+Del, to delete torrents I have to right-click and choose one of the two delete options, which is less convenient and more error-prone. Also, the KDE option talks only about selecting files and folders, and Transmission's entries in the main window are hardly those (admittedly, systemsettings also hardly deals with files or folders).

There's an option in KDE to "automatically select icons", but I fail to notice any difference between having it on and off.

Also, when I sometimes evaluate Ubuntu, I set nautilus to the single-click mode, but I don't remember having such single-clicking problems with transmission-gtk therein.

comment:3 Changed 9 years ago by lucke

  • Cc lucke@… added
  • Resolution invalid deleted
  • Status changed from closed to reopened

I'd rather leave changing of the status to the developers, but as I don't know if closed bug reports get any attention, and as I continue to be unnerved by the current behaviour, I allow myself to reopen the bug.

comment:4 Changed 9 years ago by jordan

Can you point to another Qt application that behaves in the manor that you're suggesting, so that I can look at how its code approaches the question?

IMO the app responding to the Activate event is still The Right Thing, and it's up to the system preferences to decide whether a single- or double-click triggers that event.

comment:5 Changed 9 years ago by dirleyrls

Right now I don't have any good examples to share, but I think that the best solution would be somehow changing the triggers of "actived" to work only on double clicks.

I'll write a new patch (this time with the right approach) as soon as I get home.

comment:6 Changed 9 years ago by lucke

I've just tested two filemanagers, one KDE and one pure Qt. Qtfm (pure Qt) follows KDE's settings, but Ctrl-click works for selecting. Krusader (using kdelibs) allows the user to choose whether he/she wants to use double-click or follow KDE's settings, and selecting with Ctrl works properly. As for myself, I'd be completely happy if clicking on an entry in Transmission with Ctrl or Shift pressed simply didn't open the properties window when KDE is set to single-click, like it does now.

Changed 9 years ago by dirleyrls

comment:7 Changed 9 years ago by dirleyrls

Well, I'd be happy with that Ctrl "modifier" lucke just described. But I couldn't figure how to do that, so I'm sharing a patch that "forces" the "activate on single click" style hint to be always false for the torrent list view.

comment:8 Changed 9 years ago by jordan

  • Version changed from 2.31+ to 2.31

comment:9 Changed 9 years ago by lucke

KTorrent and qBittorrent don't seem to care about KDE's single/double-click setting. With KDE set to the single-click mode, in KTorrent single-clicking selects entries in the torrent, file and plugin lists, while double-clicking starts a file manager (in case of the torrent list) or a program associated with a given filetype (in case of the file list); selecting with Ctrl and Shift works normally. Single-clicking in qBittorent also only selects.

comment:10 Changed 9 years ago by lucke

I've tested dirleyrls's patch. It makes KDE's single-click and double-click modes work in the same way, as is the case in KTorrent and qBittorrent - single-click selects entries in the torrent list, double-click opens the properties window. Double-clicking in the file list doesn't seem to do anything in qtr, selecting files there seems to be useful only for changing file's state via keyboard - patch doesn't change anything there.

Thanks, dirleyrls. Now I can select torrents, also with Ctrl and Shift, without being attacked by the properties window.

comment:11 Changed 9 years ago by xgdgsc

I really hope this can be fixed in near future. It 's annoying when I single click on items or selecting multiple items using ctrl or shift key and the properties dialog jumps in the way. I wish it behaves just like gtk version and most other bt clients.

comment:12 Changed 9 years ago by jordan

  • Milestone changed from None Set to 2.70

comment:13 Changed 9 years ago by jordan

  • Resolution set to fixed
  • Status changed from reopened to closed

I've added dirleyrls' patch in r13438. Thanks!

Note: See TracTickets for help on using tickets.