Opened 9 years ago

Closed 8 years ago

#4662 closed Bug (fixed)

WebUI file selector becomes slugish/unresponsive if torrent has a lot of files

Reported by: sergio Owned by:
Priority: Low Milestone: 2.70
Component: Web Client Version: 2.42
Severity: Normal Keywords:
Cc:

Description

When selecting the file selector for torrent with a lot of files, the webui becomes very slugish to the point where you cannot reliably do anything bit switch back to another tab/torrent. In extreme cases, eg. a torrent with about 6000 files, the page even crashes in Chrome. It would be nice if the inspector could be enhanced in such a way that it did not have to display all files at once but in a lazy way, for example though the use of pagination or by utilizing the torrents folder structure.

Change History (3)

comment:1 Changed 9 years ago by jordan

  • Priority changed from Normal to Low

comment:2 Changed 9 years ago by mirraz

Have the same problem. Example torrent-file: http://rghost.ru/37546820. It's regression after version 2.22, because transmission-2.22 works normally with this file, but transmission-2.50 can't.

uname -srmp: Linux 3.2.1-gentoo-r2 x86_64 Celeron(R) Dual-Core CPU T3000 @ 1.80GHz
browser: firefox-11.0

comment:3 Changed 8 years ago by jordan

  • Milestone changed from None Set to 2.70
  • Resolution set to fixed
  • Status changed from new to closed

This seems to be fixed now, as a side-effect of ticket #5013 which landed in 2.70.

Note: See TracTickets for help on using tickets.