Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#4682 closed Enhancement (fixed)

Add return id from "duplicate torrent" torrent-add rpc

Reported by: edmundwatson Owned by: jordan
Priority: Normal Milestone: 2.80
Component: Daemon Version: 2.42
Severity: Normal Keywords: rpc
Cc:

Description

When adding a torrent using "torrent-add" that already exists it would be useful to have the torrent id for the duplicate torrent in the output arguments.

Attachments (1)

duplicate_torrents.png (79.4 KB) - added by fguillen 8 years ago.
Duplicate torrent in the GUI Window

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by fguillen

+1

I'm in the same situation, I'm building a web interface over the Transmission API and when the User is trying to add a torrent that already exists I have the "duplicate torrent" error but I can't show to the User which torrent is.

Not only the "id" but also the "hashString" which is the only real identifier should be returned.

Actually I think all the requested attributes should be returned in the response.

comment:2 Changed 8 years ago by jordan

  • Milestone changed from None Set to 2.80
  • Owner set to jordan
  • Status changed from new to assigned

comment:3 Changed 8 years ago by fguillen

Dear Transmission support people, I know I'm not in the position to pressure you to try to solve this issue but since I'm very interested in this issue to be fixed I'd like to reward your job with an extra donation to the project, I'm not rich but I can offer around $200 as a reward for this issue to be fixed.

Hope I'm not being discourteous with my proposition.

comment:4 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

Added in r14077.

comment:5 Changed 8 years ago by fguillen

This is awesome @jordan, how can I start using this version of transmission?

comment:6 Changed 8 years ago by jordan

Easiest way is to pull a build off of https://build.transmissionbt.com/job/trunk-mac/ or https://build.transmissionbt.com/job/trunk-linux/, depending on which flavor you prefer.

If you find any issues, please reopen this ticket. It seems OK here but extra eyeballs are always welcomed, especially if we can catch issues before 2.80 comes out...

Changed 8 years ago by fguillen

Duplicate torrent in the GUI Window

comment:7 Changed 8 years ago by fguillen

Transmission version: 2.77 + (14081) OS: OSX 10.7.5

Everything works as expected, when I try to add a duplicate torrent through the RPC API I get this response:

{"arguments":{"torrent-duplicate":{"hashString":"77831ec368308f1031434c5581a76fd0c3e06cfd","id":1,"name":"No Media Kings - Ghosts With Shit Jobs trailer"}},"result":"duplicate torrent"}

Where I can see the "hashString" of the duplicated torrent, nice!.

Just one issue I've found, in the same moment I'm operating with the RPC API I've the GUI application opened and I can see how the duplicated torrent request appears duplicated in the Transmission GUI window. Check screenshot I've attached (waiting for moderation at this moment)

If I close and re-open the Transmission App the duplicated torrent has disappeared.

The duplicate situation we have in the GUI is not reproduced in the RPC API, when I ask for all the torrents through the RPC API I don't see the duplications I see in the GUI, so RPC is not affected by this "visual" duplication.

comment:8 Changed 8 years ago by fguillen

Transmission version: 2.77 + OS: Ubuntu 12.04.1 LTS

Only tested RPC API behavior, the torrent-duplicate feature works as expected.

comment:9 Changed 8 years ago by fguillen

As a proof of my gratitude to the development team I have made the donation reward I committed to. Thanks! (19F100302E414513K)

comment:10 Changed 8 years ago by livings124

Thanks fguillen!

Note: See TracTickets for help on using tickets.