Opened 9 years ago

Closed 9 years ago

#4695 closed Enhancement (duplicate)

transmission web interface leaks usage data to google

Reported by: luigi Owned by:
Priority: Low Milestone: None Set
Component: Transmission Version: 2.42
Severity: Trivial Keywords:
Cc:

Description

the files

  • jquery.min.js
  • jquery-ui.min.js
  • jquery-ui.css
  • ui-bg_flat_75_ffffff_40x100.png
  • ui-bg_glass_65_ffffff_1x400.png
  • ui-bg_glass_75_e6e6e6_1x400.png
  • ui-bg_highlight-soft_75_cccccc_1x100.png

referenced in index.html in the default web interface included with transmission are downloaded from ajax.googleapis.com. this means that every time a transmission web interface user opens the interface some data is sent to google, including, but not limited to, the url the interface is accessed from and the ip address of the browser used to access the interface. please include local copies of these files in the default transmission installation, the files are less than 100k in total, and the more privacy concerned users will benefit from this change.

thanks.

Change History (1)

comment:1 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #4548.

Note: See TracTickets for help on using tickets.