Opened 9 years ago

Closed 9 years ago

#4711 closed Bug (duplicate)

EXC_BAD_ACCESS (SIGSEGV) with specific magnet link torrents

Reported by: piru Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.42+
Severity: Major Keywords: magnet SIGSEGV EXC_BAD_ACCESS
Cc:

Description

Current Mac OS X (I'm using 10.7.2) Transmission (latest stable 13013 and latest nightly 13156) crash in a reproducible way when using specific magnet links. It's notable that the same download works when using the .torrent file.

The magnet link link I try to download is (NOTE: This is a legal download licensed under Creative Commons): magnet:?xt=urn:btih:3648ef666665eb000835408e479b5cf8ef7c1f0a&dn=Pioneer+One+S01E03+720p+x264-VODO&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.tracker.example.com%3A80&tr=udp%3A%2F%2Ftracker.ccc.de%3A80

build 13013 crash log: http://pastebin.com/Fkc4k6H9

build 13156 crash log: http://pastebin.com/eQV8Xv6W

The system log also includes the following assertion failure (only once however, even though there were numerous crashes, so this might not be related):

13.1.2012 23.34.38,147 [0x0-0x15f15f].org.m0k.transmission: Assertion failed: (tr_isPeerIo( io )), function tr_peerIoGetAddress, file /Users/transmission/hudson/workspace/trunk-mac/trunk/libtransmission/peer-io.c, line 860.

If any further details or testing is needed just ask.

Change History (1)

comment:1 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #4687

Note: See TracTickets for help on using tickets.