Opened 9 years ago

Closed 9 years ago

#4719 closed Bug (duplicate)

100% CPU usage

Reported by: WGH Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.42
Severity: Major Keywords:
Cc:

Description

Nothing much to say, really. I'm just downloading a BitTorrent? file, and transmission process eats up all CPU time. I don't remember that it happened with older 2.22 version.

I've collected profile data, and gprof output file is attached.

net-p2p/transmission-2.42 was built with the following:
USE="gtk (multilib) nls -kde -qt4 -utp"
CFLAGS="-O2 -pipe -march=core2 -ggdb -pg -ggdb -pg -ggdb -pg -ggdb -pg -ggdb -pg -ggdb -pg -ggdb -pg"
CXXFLAGS="-O2 -pipe -march=core2 -ggdb -pg -ggdb -pg -ggdb -pg -ggdb -pg -ggdb -pg -ggdb -pg -ggdb -pg"

Attachments (1)

gmon.txt.gz (56.8 KB) - added by WGH 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by WGH

comment:1 Changed 9 years ago by WGH

Please close this one. r13113 seems to fix this. Also duplicate of #4684.

comment:2 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

Job well done. :)

Note: See TracTickets for help on using tickets.