Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4722 closed Bug (duplicate)

Building from trunk throws error on po Makefile (Debian)

Reported by: Opperpanter Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.42+
Severity: Normal Keywords:
Cc:

Description

Hello,

I tried to get some feedback with this on the forum, but maybe it's better to report it here. I also tried update/comment on the wiki page on building, but I don't think I've got permission for that.

https://forum.transmissionbt.com/viewtopic.php?f=1&t=12693

I am trying to build the trunk on debian squeeze.

I installed a couple of packages (curl, libevent, ...), but am getting an error I can't explain when running autogen.sh (or configure):

[code] ... config.status: creating gtk/icons/Makefile config.status: creating web/Makefile config.status: creating web/images/Makefile config.status: creating web/style/Makefile config.status: creating web/style/jqueryui/Makefile config.status: creating web/style/jqueryui/images/Makefile config.status: creating web/style/transmission/Makefile config.status: creating web/style/transmission/images/Makefile config.status: creating web/style/transmission/images/buttons/Makefile config.status: creating web/javascript/Makefile config.status: creating web/javascript/jquery/Makefile config.status: error: cannot find input file: `po/Makefile.in.in' code

What could be wrong?

Someone suggested to create and empty po/Makefile.in.in but that still throws an error

[code] config.status: error: po/Makefile.in.in was not created by intltoolize code

I could (try to) build from source tarball, but building from trunk is much easier regarding keeping up to date.

Thanks,

Change History (5)

comment:1 Changed 9 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 9 years ago by Opperpanter

  • Resolution invalid deleted
  • Status changed from closed to reopened

Thanks for looking into this. Sorry to reopen, but what is the official solution? Just creating the makefile by hand and ignoring the.error? In that case we should update the Wiki. Let me know if I can help. Cheers.

comment:3 Changed 9 years ago by jordan

  • Resolution set to duplicate
  • Status changed from reopened to closed

This is a duplicate of #3123

comment:4 Changed 9 years ago by jordan

To answer the question, the "official" solution is to install the i18n tools that are required to generate the po/ directory's makefiles & related files.

comment:5 Changed 9 years ago by Opperpanter

Thanks, i'll try to install those and compiling again.

Maybe one day the configure/make/autgen script can check for the i18n tools being installed.

Note: See TracTickets for help on using tickets.