Opened 7 years ago

Closed 7 years ago

#4726 closed Bug (worksforme)

Incorrect window size when dock is not hidden

Reported by: yark Owned by: livings124
Priority: Lowest Milestone: None Set
Component: Mac Client Version: 2.42
Severity: Trivial Keywords: UI, window size, dock
Cc:

Description

Transmission window sometimes rich the bottom of screen and lay under dock if dock dispayed permanently so last torrent in list became unreachable, also scrollbar control and window resizer. It's happens when aumatic window size is tuned ON. I think this happens when new torrents was added or dock settings was changed to "hide" and back. Or may be when first torrent was added after last one, that fits to current screen size. Also this can be issue with second sreen (more than macbook screen) i've attached. I've notice that some programs have strange issues in case, when hibernate macos with second screen attached, than detach it and wakeup macos without that screen.

2.42 (13013) MacOS 10.6.8

Attachments (1)

overlap.jpg (184.6 KB) - added by yark 7 years ago.
Dock overlapping after Quicktime fulscreen

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by livings124

Do you have the filter and status bars shown? What happens when you hide them? What happens when you resize the dock. Is the window at the top of the screen as well?

comment:2 Changed 7 years ago by yark

Unfortunately i'm unable to reproduce it now. But recently i need to disable auto window size because of that issue. I'm try to reproduce it. Yes, filter and status bar was shown. Yes, window at the top of the screen. Nothing happens, when i resize the dock.

comment:3 Changed 7 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this either. Let's close for now, and reopen if it comes up again.

comment:4 Changed 7 years ago by yark

Please reopen. I was figure out this problem. If switch quicktime player to fulscreen with transmission window opened and auto windows size enabled, that transmission window become too long. And it can't de resized back. Do i need to attach proof screenshot?

comment:5 Changed 7 years ago by yark

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:6 Changed 7 years ago by livings124

Is this happening with 10.7? I don't believe Quicktime does fullscreen the same way in older operating systems.

comment:7 Changed 7 years ago by yark

Transmission 2.50b1 MacOS 10.6.8, as in ticket description.

comment:8 Changed 7 years ago by livings124

Can you attach the screenshot. This might just be a quirk with the old version of QuickTime?, which doesn't apply to 10.7 (which is what I'm testing on).

Changed 7 years ago by yark

Dock overlapping after Quicktime fulscreen

comment:9 Changed 7 years ago by yark

Screenshot added. It was captured before 2.5b update but yesterday it was reproduced with 2.5b too.

comment:10 Changed 7 years ago by x190

yark: That's what docks do and why they're transparent. You can put your dock on the side or better yet use Apple->Dock->Turn Hiding On (Apple->System Preferences->Dock). Move your mouse to the screen edge to see the dock as needed.

Wouldn't you want Transmission to use all the real estate it could if you did put the Dock on the side or hid it? If none of that suits you, then you can always change "automatic window size is turned ON" to OFF and resize the window as you wish (you have to scroll anyway with that many torrents loaded).

Last edited 7 years ago by x190 (previous) (diff)

comment:11 Changed 7 years ago by collegeitdept

I agree, lets all please stop filing trivial bugs whereby delaying official releases of Transmission. Lets hope 2.5 will be out this month!

comment:12 Changed 7 years ago by livings124

What does this have to do with the release of 2.5? This is a valid bug (well, potentially anyway).

comment:13 Changed 7 years ago by yark

I'm helping opensource community as i can. If you think this si trivial and don't need to be fixed it is your choice. For me i don't want to hide dock or send it to side. I just turn off auto window size now as i did when faced to this issue.

comment:14 Changed 7 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

I believe this is related to full-screen QuickTime? in 10.6, which behaves differently than Lion fullscreen. Since this isn't replicable on Lion, I'm going to resolve. Please reopen if it can be recreated.

Note: See TracTickets for help on using tickets.