Opened 7 years ago

Closed 7 years ago

#4743 closed Bug (duplicate)

Crash while opening torrent file after canceling same magnet link

Reported by: tstevens Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.42
Severity: Normal Keywords:
Cc:

Description

After opening a torrent file Transmission crashed while loading from the auto add directory due to a failed assertion. I've attached the crash log below.

Attachments (3)

Transmission_2012-01-30-182234.crash (43.9 KB) - added by tstevens 7 years ago.
Transmission_2012-01-30-192941_.crash (42.9 KB) - added by tstevens 7 years ago.
Transmission_2012-01-30-200311.crash (44.3 KB) - added by tstevens 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by tstevens

comment:1 Changed 7 years ago by livings124

Is this crash reproducible? Does it crash with 2.42?

Changed 7 years ago by tstevens

comment:2 Changed 7 years ago by tstevens

I have been able to reproduce it on rev 13185 multiple times. The sequence is: with transmission closed click a magnet link, cancel adding, then add torrent file for the same torrent as the magnet link to auto add directory (have not tried opening the torrent file manually) and transmission will crash.

comment:3 Changed 7 years ago by livings124

  • Summary changed from Crash while opening torrent to Crash while opening torrent file after canceling same magnet link

Does this happen with 2.42?

Changed 7 years ago by tstevens

comment:4 Changed 7 years ago by tstevens

Yes. Attached another crash log from 2.42.

comment:5 Changed 7 years ago by livings124

  • Version changed from 2.42+ to 2.42

comment:6 Changed 7 years ago by jordan

54	0   libsystem_kernel.dylib              0x00007fff87eb7ce2 __pthread_kill + 10
55	1   libsystem_c.dylib                   0x00007fff8944f7d2 pthread_kill + 95
56	2   libsystem_c.dylib                   0x00007fff89440a7a abort + 143
57	3   libsystem_c.dylib                   0x00007fff894735de __assert_rtn + 146
58	4   org.m0k.transmission                0x000000010006b1f1 torrentRecheckDoneImpl + 101
59	5   org.m0k.transmission                0x0000000100076a3d readFromPipe + 274

comment:7 Changed 7 years ago by x190

FWIW, I could not reproduce this crash with 2.42 +(13112) on OS X 10.6.8. Admittedly, I had to use the Command-U dialog to add the magnet link, but I don't think that would matter?

comment:8 Changed 7 years ago by jordan

Seems to be dying in the "assert(tr_isTorrent(tor))" assertion in torrentRecheckDoneImpl(). However, like x190, I'm not able to trigger this crash either. (Though I'm not on OS X)

tstevens, could you walk through a more detailed recipe of how to trigger this? I'd like to reproduce it here inside a debugger for closer inspection. Thanks!

comment:9 Changed 7 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a duplicate of #4687

Note: See TracTickets for help on using tickets.