Opened 15 years ago

Closed 14 years ago

#475 closed Bug (worksforme)

Transmission corrupts very large torrents

Reported by: greatcaffeine Owned by: somebody
Priority: Normal Milestone: None Set
Component: Transmission Version: 0.93
Severity: Normal Keywords:
Cc:

Description

OS X 10.5.0 (Intel 32-bit) Transmission 0.93 (bug has been present for several releases)

Transmission will regularly lose data on very large torrents (6.94GB in this case). The torrent can get pretty close to completion, usually around 90% finished, but if I try to verify the existing data, the progress resets to ~5% and essentially has to start over again.

From what I can tell, I've been dealing with this bug in both Tiger and Leopard, so it doesn't seem to be a Leopard specific issue.

Change History (4)

comment:1 Changed 15 years ago by charlieMonroe

This isn't a big. Check the log whenever this happens - a piece check just failed, so the downloaded data has been thrown away. This does every torrent client, though some offer the ability to ban (manually) IP addresses of people who send bad data too often. I am not the Transmission developer, but this is the way it goes...

comment:2 Changed 15 years ago by greatcaffeine

Transmission is the only client that gives me serious problems with this. I understand that bad data will show up from time to time and it has to get pitched, but what I don't understand is why Azureus and µTorrent both get the job done while Transmission has to throw away the majority of what was downloaded.

comment:3 Changed 14 years ago by livings124

Are you still seeing this on .96?

comment:4 Changed 14 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

No one else is seeing this on the latest release.

Note: See TracTickets for help on using tickets.