Opened 7 years ago

Closed 4 years ago

#4759 closed Bug (worksforme)

Accentuated characters are not supported in NTFS target folder

Reported by: freebourg Owned by: jordan
Priority: Low Milestone: None Set
Component: Qt Client Version: 2.33
Severity: Major Keywords: filesystem unicode folder
Cc:

Description

I have a folder on a NTFS partition that is called "Téléchargements". I can select it as a target folder, but after closing the file chooser, QtTransmission? replaces the "é" in its name with weird characters. I think this is due of encoding issues between UTF-8 on my Linux box and another encoding on the NTFS partition.

There is also another bug for the same reason: I had a symbolic link for the drive, and when I used it with the accentuated folder name, Transmission would heavily slow down and freeze, every time it unfreezes the target folder would be 1 character longer. There was an infinite loop when it encountered the "é" character. It would download files correctly if I managed to press the "OK" button.

The third bug related to that issue: My default target folder was set to this accentuated folder, and when I wanted to choose another download location while adding a torrent, the FileChooser? took 30 seconds to get out from that directory.

The partition is mounted like this on Kubuntu 11.10:

/dev/sdc2 on /mnt/MEDIA_DRIVE type fuseblk (rw,noexec,nosuid,nodev,allow_other,blksize=4096)

using default Ubuntu ntfs driver, not the ntfs-3g one.

I fixed the problem by creating a symbolic link with no spaces, no accentuated characters and what so ever. I didn't experienced problems with accentuated torrent files and folders though, which is strange ?!

Transmission works correctly with acccentuated characters on my ext4 partition.

Other programs handle the NTFS accentuated folder very well unlike Transmission.

However, people writing to a NTFS partition on Linux or Mac have to know their stuff and be prepared to get in trouble with unofficial OS support for NTFS writing. Then it's OK if you guys developing Transmission just don't support NTFS at all.

Change History (6)

comment:1 Changed 7 years ago by x190

Same issue as #4753?

comment:2 Changed 7 years ago by IAmTheClaw

Not the same issue as #4753. NTFS uses UTF-16LE (IIRC, could be BE), so it supports Unicode characters. #4753 has to do with characters that aren't allowed (e.g., colons and backslashes). I think this issue is a problem with the client and not the daemon.

comment:3 Changed 4 years ago by mike.dld

Anyone to confirm that this is still an issue? Unfortunately I only have ntfs3g here and don't know what "default Ubuntu ntfs driver" was at the time of writing, but my testing indicates no described behavior.

comment:4 Changed 4 years ago by cfpp2p

Replying to mike.dld:

Anyone to confirm that this is still an issue?

I can't confirm, however...

The below statements are untrue for me. Recent transmission versions in my tests with ntfs Linux and Windows implementations have not given me the problems described.

Other programs handle the NTFS accentuated folder very well unlike Transmission.

Then it's OK if you guys developing Transmission just don't support NTFS at all.

comment:5 Changed 4 years ago by freebourg

Ubuntu is now shipping with ntfs-3g which was merged with ntfsprogs.

I can't say for Ubuntu, but I just tested QtTransmission? 2.84 (14307) with ntfs-3g 2014.2.15 on Archlinux, and the issue is non-existent or resolved.

cfpp2p: What do you mean? Are having trouble with non-ASCII characters on a NTFS partition? Or are you doubting other programs have trouble with NTFS? Or are you saying Transmission doesn't have any trouble with NTFS?

What I meant back then is that Dolphin (KDE file manager) and media players (e.g. VLC) handle the non-ASCII folder name very well while Transmission had trouble with it, that's all. It seems OK now as explained.

comment:6 Changed 4 years ago by mike.dld

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks guys, I'm closing it then. Feel free to reopen at any time.

Note: See TracTickets for help on using tickets.