Opened 7 years ago

Closed 7 years ago

#4778 closed Bug (invalid)

Selecting/deselecting files in web interface does not always work

Reported by: tschmelcher Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.33
Severity: Normal Keywords:
Cc:

Description

I am using transmission 2.33 on Ubuntu 11.10 (installed from APT). When using the web interface in Chrome, it is impossible to select or deselect files in the Inspector. Clicking on the checkboxes or on Select All / Deselect All has no effect. Running Chrome 16.0.912.77.

It works fine in Firefox.

Change History (6)

comment:1 Changed 7 years ago by livings124

Does this work for you in 2.42/2.5?

comment:2 Changed 7 years ago by tschmelcher

Actually, moments after filing I discovered that the problem doesn't behave the way I said it does. It's not that it's always broken in Chrome and working Firefox. Rather, it breaks in both, but only after pausing or resuming a torrent in the web interface. Once I do that, selecting/deselecting files (incl. for a different torrent) stops working. The problem fixes itself if I refresh the page (closing and re-opening the inspector is not enough).

I'll test a later version too.

comment:3 Changed 7 years ago by tschmelcher

  • Summary changed from Cannot select or deselect files in web interface with Chrome browser to Selecting/deselecting files in web interface does not always work

Actually, moments after filing I discovered that the problem doesn't behave the way I said it does. It's not that it's always broken in Chrome and working Firefox. Rather, it breaks in both, but only after pausing or resuming a torrent in the web interface. Once I do that, selecting/deselecting files (incl. for a different torrent) stops working. The problem fixes itself if I refresh the page (closing and re-opening the inspector is not enough).

I'll test a later version too.

comment:4 Changed 7 years ago by x190

tschmelcher: "if I refresh the page": This should be done automatically within 5 seconds.

common.js:

Prefs._Defaults =
{
        'filter': 'all',
	'refresh_rate' : 5,

Even in the Mac Client there often is a short period of unresponsiveness when selecting/deselecting additional files in an active torrent. It clears itself if you wait a few seconds after making your selection.

comment:5 Changed 7 years ago by tschmelcher

Hmm, that refresh_rate setting is indeed present in my common.js, but the web UI definitely is not refreshing every 5 seconds. The progress bars and rates update often (more often than 5 seconds, it seems), but it never refreshes the page itself. I tried waiting for over 10 seconds and the problem did not go away.

comment:6 Changed 7 years ago by tschmelcher

  • Resolution set to invalid
  • Status changed from new to closed

Tested 2.42 from the PPA and selecting/deselecting files appears to work reliably.

Note: See TracTickets for help on using tickets.