Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#4788 closed Bug (fixed)

"export TRANSMISSION_HOME=" broken

Reported by: x190 Owned by: livings124
Priority: Normal Milestone: 2.51
Component: Mac Client Version: 2.50
Severity: Normal Keywords:
Cc:

Description

Setting "export TRANSMISSION_HOME=" does not work with Mac Client nightly .dmgs post r13013 on 10.6.8. Also tested 2.50 release. It does work with 2.42 release .dmg.

Change History (7)

comment:2 Changed 6 years ago by livings124

  • Version changed from 2.42+ to 2.50

comment:3 Changed 6 years ago by jordan

TRANSMISSION_HOME=xxx is working on the GTK+ side, FWIW. I don't know what the cause of this problem is, but at first glance I suspect it's something going on in the Mac build.

comment:4 Changed 6 years ago by x190

Works: r13013 Controller.m Line 322

const char * configDir = tr_getDefaultConfigDir("Transmission");
        fLib = tr_sessionInit("macosx", configDir, YES, &settings);
        tr_bencFree(&settings);

Broken: r13230 Controller.m Line 323

//use this instead of tr_getDefaultConfigDir("Transmission") so we are sure to get the "real" Application Support directory
        const char * configDir = [[[NSSearchPathForDirectoriesInDomains(NSApplicationSupportDirectory, NSUserDomainMask, YES) objectAtIndex: 0] stringByAppendingPathComponent: @"Transmission"] UTF8String];
        fLib = tr_sessionInit("macosx", configDir, YES, &settings);
        tr_bencFree(&settings);

Suggested Fix: r13230 or higher

-Line 323-325:
//use this instead of tr_getDefaultConfigDir("Transmission") so we are sure to get the "real" Application Support directory
        const char * configDir = [[[NSSearchPathForDirectoriesInDomains(NSApplicationSupportDirectory, NSUserDomainMask, YES) objectAtIndex: 0] stringByAppendingPathComponent: @"Transmission"] UTF8String];
        fLib = tr_sessionInit("macosx", configDir, YES, &settings);


+Line 323-324:
const char * configDir = tr_getDefaultConfigDir("Transmission");
        fLib = tr_sessionInit("macosx", configDir, YES, &settings);


comment:5 Changed 6 years ago by livings124

This is caused by r13178

comment:6 Changed 6 years ago by livings124

  • Milestone changed from None Set to 2.51
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from "export TRANSMISSION_HOME=" broken on SL 10.6.8 post r13013 Mac Client .dmgs to "export TRANSMISSION_HOME=" broken

Fixed in r13240

comment:7 Changed 6 years ago by x190

Gracias! :)

Note: See TracTickets for help on using tickets.