Opened 9 years ago

Closed 9 years ago

#4835 closed Bug (duplicate)

transmission-gtk-2.50 segmentation fault when adding links

Reported by: samuli Owned by: jordan
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.50
Severity: Major Keywords:
Cc: ThyArmageddon+Gentoo@…

Description

This is a forward from downstream bug report, http://bugs.gentoo.org/408067

System is x86_64, Linux, GCC 4.5, GLIBC 2.13

Backtrace, http://bugs.gentoo.org/show_bug.cgi?id=408067#c7

Starting program: /usr/bin/transmission-gtk [Thread debugging using libthread_db enabled] [New Thread 0x7fffedb4b700 (LWP 16194)] [New Thread 0x7fffed34a700 (LWP 16195)] [New Thread 0x7fffe7fff700 (LWP 16196)] [New Thread 0x7fffe77fe700 (LWP 16197)] [New Thread 0x7fffe6ffd700 (LWP 16198)]

Program received signal SIGABRT, Aborted. 0x00007ffff4d8c435 in raise () from /lib64/libc.so.6 #0 0x00007ffff4d8c435 in raise () from /lib64/libc.so.6 #1 0x00007ffff4d8d6da in abort () from /lib64/libc.so.6 #2 0x00007ffff6046c31 in g_assertion_message (domain=<optimized out>,

file=<optimized out>, line=<optimized out>, func=0x493be0 "gtr_torrent_options_dialog_new", message=0x7ffff6094978 "code should not be reached") at gtestutils.c:1425

#3 0x0000000000433c9e in gtr_torrent_options_dialog_new (parent=0x810df0,

core=0x74a820, ctor=0xa40100) at open-dialog.c:284

#4 0x000000000042e2fb in on_add_torrent (core=<optimized out>,

ctor=<optimized out>, gdata=<optimized out>) at main.c:1053

#5 0x00007ffff6718e34 in g_closure_invoke (closure=0x886970,

return_value=0x0, n_param_values=2, param_values=0xa1b320, invocation_hint=<optimized out>) at gclosure.c:774

#6 0x00007ffff672bee1 in signal_emit_unlocked_R (node=<optimized out>,

detail=0, instance=0x74a820, emission_return=0x0, instance_and_params=0xa1b320) at gsignal.c:3272

#7 0x00007ffff67352e2 in g_signal_emit_valist (instance=<optimized out>,

signal_id=<optimized out>, detail=0, var_args=0x7fffffffd620) at gsignal.c:3003

#8 0x00007ffff6735483 in g_signal_emit (instance=<optimized out>,

signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3060

#9 0x00000000004389c5 in core_add_ctor (core=0x74a820, ctor=0xa40100,

do_prompt=1, do_notify=0) at tr-core.c:1021

#10 0x0000000000438d94 in add_file_async_callback (file=0xa1acd0,

result=0x7fffe80015e0, gdata=0xa3db00) at tr-core.c:1088

#11 0x00007ffff69c5d79 in g_simple_async_result_complete (

simple=0x7fffe80015e0) at gsimpleasyncresult.c:749

#12 0x00007ffff6999e4f in load_contents_close_callback (obj=<optimized out>,

close_res=<optimized out>, user_data=0xa3d8b0) at gfile.c:6266

#13 0x00007ffff69b4d58 in async_ready_close_callback_wrapper (

source_object=0x9d2b40, res=0x93a5e0, user_data=0xa3d8b0) at ginputstream.c:484

#14 0x00007ffff69c5d79 in g_simple_async_result_complete (simple=0x93a5e0)

at gsimpleasyncresult.c:749

#15 0x00007fffe65e5515 in ?? () from /usr/lib64/gio/modules/libgvfsdbus.so #16 0x00007fffe65e2ee5 in ?? () from /usr/lib64/gio/modules/libgvfsdbus.so #17 0x00007fffe65e311f in ?? () from /usr/lib64/gio/modules/libgvfsdbus.so #18 0x00007fffe65e327c in ?? () from /usr/lib64/gio/modules/libgvfsdbus.so #19 0x00007ffff69b4dd5 in async_ready_callback_wrapper (

source_object=0x9d3c00, res=0x93a460, user_data=0xa2ba30) at ginputstream.c:470

#20 0x00007ffff69c5d79 in g_simple_async_result_complete (simple=0x93a460)

at gsimpleasyncresult.c:749

#21 0x00007ffff69ee390 in read_async_cb (fd=<optimized out>,

condition=<optimized out>, data=<optimized out>) at gunixinputstream.c:483

#22 0x00007ffff6021f92 in g_main_dispatch (context=0x707e70) at gmain.c:2441 #23 g_main_context_dispatch (context=0x707e70) at gmain.c:3011 #24 0x00007ffff6022770 in g_main_context_iterate (context=0x707e70, block=1,

dispatch=1, self=<optimized out>) at gmain.c:3089

#25 0x00007ffff6022cba in g_main_loop_run (loop=0x9a6ca0) at gmain.c:3297 #26 0x00007ffff69f693b in g_application_run (application=0x70fc60,

argc=<optimized out>, argv=<optimized out>) at gapplication.c:1323

#27 0x000000000042f437 in main (argc=1, argv=0x7fffffffdf58) at main.c:657

Attachments (1)

bt.txt (3.6 KB) - added by samuli 9 years ago.
Same backtrace as in the bug report in attachment

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by samuli

Same backtrace as in the bug report in attachment

comment:1 Changed 9 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket #4573

Note: See TracTickets for help on using tickets.