Opened 9 years ago

Closed 8 years ago

Last modified 5 years ago

#4858 closed Bug (invalid)

TR_TORRENT_DIR points to the download folder

Reported by: juanfal Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.51
Severity: Normal Keywords:
Cc:

Description

The TR_TORRENT_DIR env variable sometimes get stuck pointing to the downloading folder, not the final folder where the item has just moved.

Change History (5)

comment:1 Changed 8 years ago by jordan

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

  • Is this reproducible?
  • If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

comment:2 Changed 8 years ago by juanfal

Not seen anymore!

comment:3 Changed 8 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

This bug report is being closed due to your last comment regarding this being fixed with an update. Please reopen this bug if the problem recurs. Thank you again for taking the time to report this bug and helping to make Transmission better.

comment:4 Changed 5 years ago by MrCee

Is anyone able to help point me in the right direction to the code that was changed to fix this issue?

Synology Download Station is based on Transmission and is having the same problem since DSM 5.1.

I have raised this with Synology several times to no avail. Some help from the Transmission team would be greatly appreciated.

In summary, the ENVIRONMENT VARIABLE : TR_TORRENT_DIR returns the incomplete/temp path and does not point to the GUI specified download location.

Thanks!

Last edited 5 years ago by MrCee (previous) (diff)

comment:5 Changed 5 years ago by x190

if (script && *script)
    {
...
        tr_strdup_printf ("TR_TORRENT_DIR=%s", tor->currentDir),

Take a look at libtransmission/torrent.c and check your code against trunk wherever currentDir is set.

Check your logfile for error messages. Please use the forum for support issues.

Note: See TracTickets for help on using tickets.