Opened 9 years ago

Closed 9 years ago

#4867 closed Bug (fixed)

Some strings are not translated in Transmission in Ubuntu 12.04

Reported by: jordan Owned by: jordan
Priority: Normal Milestone: 2.52
Component: GTK+ Client Version: 2.51
Severity: Normal Keywords:
Cc:

Description

Downstream ticket: https://bugs.launchpad.net/ubuntu/+source/transmission/+bug/979151


A few strings ("Downloading", "Seeding" and "Verfying" are not translated as can be seen on attached image.

As strings are present in the template they are quite possibly not getting exported.

The issue is in filter.c

static GtkTreeModel * activity_filter_model_new( GtkTreeModel * tmodel ) ...

{ ACTIVITY_FILTER_DOWNLOADING, NC_( "Verb", "Downloading" ), GTK_STOCK_GO_DOWN },

...

etc

http://developer.gnome.org/glib/2.31/glib-I18N.html#NC-:CAPS states:

"Only marks a string for translation, with context. This is useful in situations where the translated strings can't be directly used, e.g. in string array initializers. To get the translated string, you should call g_dpgettext2() at runtime. "

which the code doesn't do

Change History (2)

comment:1 Changed 9 years ago by jordan

  • Status changed from new to assigned

comment:2 Changed 9 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r13284

Note: See TracTickets for help on using tickets.