Opened 9 years ago

Closed 9 years ago

#4924 closed Enhancement (wontfix)

Use recycleURLs:completionHandler: to trash files

Reported by: livings124 Owned by: livings124
Priority: Low Milestone: None Set
Component: Mac Client Version: 2.52
Severity: Minor Keywords:
Cc:

Description

recycleURLs:completionHandler: moves files to the trash in the same manner as the file, so it's the best way to delete user-facing files.

Change History (4)

comment:1 Changed 9 years ago by livings124

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:2 Changed 9 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 9 years ago by livings124

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reverting in r13334. This works incorrectly because of bugs in libtransmission involving removing files.

comment:4 Changed 9 years ago by livings124

  • Milestone changed from 2.60 to None Set
  • Resolution set to wontfix
  • Status changed from reopened to closed

The benefit of this is outweighed by the garbage folder left in the directory of the deleted file, caused by a bug(s) in libtransmission.

Note: See TracTickets for help on using tickets.