Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4925 closed Bug (wontfix)

Group "Custom location" reverts when selecting "Other"

Reported by: dbmikus Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.52
Severity: Minor Keywords:
Cc:

Description

I am running Transmission 2.52 (13304) on Mac OS X 10.7.4. When I go into Preferences > Groups, there is a check box for "Custom location". I currently have 7 groups. I have custom locations enabled for each one of them. When I select the drop down menu and choose "Other" to bring up the native filesystem browser, the starting directory viewed is not the one set for the current group, but is instead the one set for the most recently set group.

To clarify, let's say I have two groups: Movies, and Music. I set the Movies custom location to ~/Movies/Unsorted and the Music custom location to ~/Music/Unsorted, setting them in the order listed. Then I go back to Movies and choose the custom location "Other" to change it using the native filesystem browser. It will default to ~/Music/Unsorted instead of ~/Movies/Unsorted.

I'm almost 100% certain that it doesn't actually change the location where it stores the files for a group. I think it is just an error with what we see as the default location in the filesystem browser. I can update when torrents finish downloading to make sure that they all went to the same place.

Change History (4)

comment:1 Changed 9 years ago by livings124

Are you saying that when the sheet displays, the starting location is arbitrary? That shouldn't effect the choice.

This happens with all sheets in the app, right?

comment:2 Changed 9 years ago by dbmikus

When I click on a group and the sheet pops up, it displays the sheet of the previously chosen group, instead of the location of the currently selected group.

It does this for all sheets.

comment:3 follow-up: Changed 9 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

I'm conflicted on what to do with this. Both ways have benefits, with the current way allowing you to access the most-recently accessed location. Apple is not consistent with this: Mail does it how Transmission does. I'm going to lean towards keeping existing behavior.

comment:4 in reply to: ↑ 3 Changed 9 years ago by dbmikus

Replying to livings124:

I'm conflicted on what to do with this. Both ways have benefits, with the current way allowing you to access the most-recently accessed location. Apple is not consistent with this: Mail does it how Transmission does. I'm going to lean towards keeping existing behavior.

If I learned some of the source code and eventually coded this in so that it shows the current directory for the group, would that be behavior that you would let in? My issue is, if you have TV shows go to ~/TV/Unsorted and music goes to ~/Music/Unsorted, then in the preferences window, you will see that they both reside in the folder Unsorted, but when you open up the sheet to view where that directory resides in your filesystem, it won't actually show you. The issue is that there is no way to check where we automatically moving the files.

Note: See TracTickets for help on using tickets.