Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#4957 closed Bug (worksforme)

tracker.ibiblio.org:80 Announce error: Could not connect to tracker

Reported by: moo Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.60
Severity: Normal Keywords:
Cc:

Description

using "tcpdump -niany host tracker.ibiblio.org" i don't see any traffic when transmission connects to it, i can see tcp request when i do telnet tracker.ibiblio.org 80

Change History (10)

comment:1 Changed 9 years ago by x190

Temporary perhaps? I get an immediate response with 2.60 +(13375).

Don't forget the "/announce" when adding this tracker.

tracker.ibiblio.org:80/announce

Last edited 9 years ago by x190 (previous) (diff)

comment:2 Changed 9 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

This seems like a tracker-specific issue to me. Please reopen with more information if it's not.

comment:3 Changed 9 years ago by moo

torrent is attached. and can be downloaded from http://terasaur.org/item/downloads/flightgear-v2-6-0/214 it's permanent. i've uploaded it to torrent for half a day without success announcing. bitcomet has no problem with tracker.ibiblio.org:80/ maybe bitcomet try adding /announce automatically? or the website server redirect by checking user-agent header correctly for bitcomet? but this has nothing to do with "no tcpdump output" i saw

comment:4 Changed 9 years ago by x190

While I do connect and get peers (using a test torrent from above link) and start d/ling at full speed, there's no doubt about all the re-directs you mention. netstat shows as many as 6 addresses all on TIME_WAIT. The only problem I see, and this is persistent across many versions is that while getting varying numbers of total peers the seed/leech numbers get "stuck" and do not reflect the peers received value correctly.

"tcpdump -niany host tracker.ibiblio.org" likely doesn't get any hits as everything is re-directed through one of it's numerous other servers.

========================================================================= terasaur != dinosaur:

http://www.ibiblio.org/terasaur/ =========================================================================

Last edited 9 years ago by x190 (previous) (diff)

comment:5 Changed 9 years ago by moo

i still don't get it i wonder why "tcpdump -niany host tracker.ibiblio.org" before adding the torrent showed nothing before the redirect happens. there should be a request and a "redirect" response

in torrent property in bitcomet, i can see http://tracker.ibiblio.org/announce. while in transmission web ui it's http://tracker.ibiblio.org:80, just like any other torrents in transmission.

opening http://tracker.ibiblio.org/announce in chrome gets d14:failure reason17:info hash missing opening http://tracker.ibiblio.org/ in chrome gets redirected to http://terasaur.org/

comment:6 Changed 9 years ago by moo

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 2.60 to 2.61

reproduced with http://tim.purewhite.id.au/2011/06/disable-ipv6-in-transmission-bt/ "bind-address-ipv6": "fe80::"

not reproduced with "bind-address-ipv6": "::", i really want to disable IPv6 support in transmission

comment:7 Changed 9 years ago by livings124

  • Version changed from 2.61 to 2.60

comment:8 Changed 9 years ago by jordan

  • Resolution set to worksforme
  • Status changed from reopened to closed

I'm not able to reproduce the original error reported in this ticket. When I open a torrent from the ibiblio link above, Transmission's announce works correctly and things start downloading.

Regarding the reopened issue, I'm not sure why you're asking the Transmission developers to do triage on a feature that we've already declined (#4197).

comment:9 Changed 9 years ago by moo

sorry, i didn't know that feature request. but i do think connection to ipv4 tracker should not fail silently. just because ipv6 setting in transmission is mis-configured. '"bind-address-ipv6": "fe80::"' is a "more information" to the original report of this ticket

anyway, thanks for your time. maybe i should have checked the log

comment:10 Changed 7 years ago by kappa

The IPv4 (TCP, not UDP) trackers not connectable with "bind-address-ipv6": "fe80::" is a duplicate of #4327, isn't it? Same problem here on 2.82 (14160).

Note: See TracTickets for help on using tickets.