Opened 9 years ago

Closed 9 years ago

#4977 closed Bug (fixed)

Rev 13388: gtk required

Reported by: sebastianmarkow Owned by: jordan
Priority: Normal Milestone:
Component: Transmission Version: 2.60+
Severity: Normal Keywords: gtk, requirements
Cc:

Description

Since nightly rev 13388 GTK is required even for daemon build on headless *nix.

checking for GTK... configure: error: Package requirements (gtk+-3.0 >= 3.2.0
                              glib-2.0 >= 2.32.0
                              gio-2.0 >= 2.26.0,
                              gmodule-2.0 >= 2.32.0
                              gthread-2.0 >= 2.32.0) were not met:

No package 'gtk+-3.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Change History (2)

comment:1 Changed 9 years ago by jordan

  • Milestone None Set deleted
  • Owner set to jordan
  • Status changed from new to assigned

comment:2 Changed 9 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

jordan * r13394 /trunk/configure.ac: (trunk) #4977 "Rev 13388: gtk required" -- fix r13388 regression in configure.ac that required GTK+ even if only building transmission-daemon.

Note: See TracTickets for help on using tickets.