Opened 9 years ago

Closed 9 years ago

#4986 closed Bug (wontfix)

GTK+ 3 required

Reported by: jue Owned by: jordan
Priority: High Milestone: None Set
Component: GTK+ Client Version: 2.60+
Severity: Major Keywords:
Cc:

Description

Latest version of transmission (2.61) depends on GTK+ 3.x, support for version 2 of GTK+ has been dropped. These is a very big change for a minor release, particularly the release includes furthermore a security fix for the web frontend. That way distributions might be forced to patch 2.60 for the security fix, because GTK+ 3 is not available everywhere.

I'd suggest to keep support for GTK+ 2 or move the switch to GTK+ 3 to a transmission release 2.70 or even 3.00 and create a 2.61 mainly for the security and other fixes.

Thanks.

Change History (1)

comment:1 Changed 9 years ago by jordan

  • Resolution set to wontfix
  • Status changed from new to closed

In general I agree, but since the next release will be 2.70 I think the practical effects of this jump will be less than this ticket's description suggests.

For those who need it, the patch against 2.61 can be found at https://trac.transmissionbt.com/changeset/13392/

Note: See TracTickets for help on using tickets.