Opened 8 years ago

Closed 7 years ago

Last modified 5 years ago

#4987 closed Bug (fixed)

character entities are not rendered

Reported by: pieska Owned by: jordan
Priority: Normal Milestone:
Component: Web Client Version: 2.61
Severity: Normal Keywords:
Cc: nodiscc@…, peron.clem@…

Description

the arrows indicating up/download in the torrent view are shown as '↑' and '%darr;'.

setInnerHTML() was replaced by setTextContent() in web/javascript/torrent-row.js. reverting the change (see transmission-dlul.patch) fixes the issue.

Attachments (5)

transmission-dlul.patch (1.5 KB) - added by pieska 8 years ago.
arrows.patch (713 bytes) - added by sergio 8 years ago.
Use unicode instead of HTML escape codes
transmission.png (64.2 KB) - added by mudd1 7 years ago.
screenshot of bug in transmission 2.77
file-row.js (4.3 KB) - added by frozeus 7 years ago.
torrent-row.js (9.7 KB) - added by frozeus 7 years ago.

Download all attachments as: .zip

Change History (28)

Changed 8 years ago by pieska

comment:1 Changed 8 years ago by jordan

  • Owner set to jordan
  • Status changed from new to assigned

Thanks for the heads-up!

comment:2 Changed 8 years ago by jordan

  • Version changed from 2.60+ to 2.61

Changed 8 years ago by sergio

Use unicode instead of HTML escape codes

comment:3 Changed 8 years ago by sergio

I believe using Unicode instead of HTML escape codes is the smarter choice instead of working around the problem with using innerHTML() which affects more then just the problematic symbols.

comment:4 Changed 8 years ago by livings124

  • Milestone changed from None Set to 2.70

comment:5 Changed 8 years ago by livings124

  • Resolution set to fixed
  • Status changed from assigned to closed

r13421 applies sergio's patch. Thanks!

comment:6 Changed 8 years ago by zp_

The filelist in the inspector tab is also bugged for me (using Chrome and the 2.61 webui), for example it shows

archlinux-2012.​08.​04-dual.​iso

instead of archlinux-2012.08.04-dual.iso

as it appears in the 2.52 webui

Last edited 8 years ago by zp_ (previous) (diff)

comment:7 Changed 8 years ago by livings124

Can you open that as a new ticket?

comment:8 Changed 8 years ago by Bugmenot

the arrows patch is being stripped, so it will not (still display correctly)

Verify its being stripped by looking at the actual commit/changeset #13421

cheers.

comment:9 follow-up: Changed 8 years ago by Bugmenot

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have double triple checked. Once the patch goes in it gets mangled and results on displaying return '↑ ' + Transmission.fmt.speedBps(t.getUploadSpeed()); instead of the arrow ↑ or ↓

this can be triple checked by actually clicking the patch link https://trac.transmissionbt.com/attachment/ticket/4987/arrows.patch and see what the commit is also mangled.

looking at the patch source downloading it locally and viewing all is well.

Since no one seems to NOTICE Im reopening this so someone actually has to look at cause.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 8 years ago by sergio

Replying to Bugmenot:

I have double triple checked. Once the patch goes in it gets mangled and results on displaying return '↑ ' + Transmission.fmt.speedBps(t.getUploadSpeed()); instead of the arrow ↑ or ↓

this can be triple checked by actually clicking the patch link https://trac.transmissionbt.com/attachment/ticket/4987/arrows.patch and see what the commit is also mangled.

looking at the patch source downloading it locally and viewing all is well.

Since no one seems to NOTICE Im reopening this so someone actually has to look at cause.

No one has noticed because this is a Trac issue, not a source issue. Take a look at the svn checkout. Since I believe transmission is being build from svn and not from Trac, I personally could not care less how Trac displays it.

comment:11 in reply to: ↑ 10 Changed 8 years ago by Bugmenot

Replying to sergio:

No one has noticed because this is a Trac issue, not a source issue. Take a look at the svn checkout. Since I believe transmission is being build from svn and not from Trac, I personally could not care less how Trac displays it.

Actually its NOT a trac issue alone, I can easily verify this since builds from 2.61 display this bug and the other bug (related) https://trac.transmissionbt.com/ticket/5008

I cant be sure about the UI but the web interfaces all have these bugs.

comment:12 follow-up: Changed 8 years ago by livings124

This is marked as fixed in 2.70, not 2.61.

comment:13 in reply to: ↑ 12 Changed 8 years ago by Bugmenot

Replying to livings124:

This is marked as fixed in 2.70, not 2.61.

I said from 2.61 that includes the bug this patch intends to fix.

But if we get pedantic, what I describe is happening in trunk and if it happens in trunk it will happen in tagged versions.

I dont care either way I fixed this in my local files.

comment:14 Changed 8 years ago by sergio

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:15 Changed 8 years ago by nodiscc

  • Cc nodiscc@… added

Changed 7 years ago by mudd1

screenshot of bug in transmission 2.77

comment:16 follow-up: Changed 7 years ago by mudd1

  • Resolution fixed deleted
  • Status changed from closed to reopened

I attached a screenshot of the bug which shows that this is still present for me in 2.77. Any ideas why this might be?

comment:17 Changed 7 years ago by mudd1

Ok, this only happened shortly after upgrading. Even though I tried to restart about anything that could be restarted, only waiting some time eventually helped. What I want to say: this somehow fixed itself so just ignore my last message.

comment:18 Changed 7 years ago by x190

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:19 in reply to: ↑ 16 Changed 7 years ago by x190

Replying to mudd1:

I attached a screenshot of the bug which shows that this is still present for me in 2.77. Any ideas why this might be?

v2.80 was released 26 June 2013.

Replying to mudd1:

Ok, this only happened shortly after upgrading. Even though I tried to restart about anything that could be restarted, only waiting some time eventually helped. What I want to say: this somehow fixed itself so just ignore my last message.

Ticket closed.

Last edited 7 years ago by x190 (previous) (diff)

Changed 7 years ago by frozeus

Changed 7 years ago by frozeus

comment:20 Changed 7 years ago by frozeus

I'm using the transmission-daemon 2.82 and the issue is not fixed.

My O/S is Debian 7 64 and My Browser is Google Chrome 29 (Encoding is UTF-8).

Why not subsitute the HTML Entity by the unicode Character ?

comment:21 Changed 7 years ago by frozeus

  • Cc peron.clem@… added
  • Milestone 2.70 deleted
  • Version changed from 2.61 to 2.75

comment:22 Changed 7 years ago by livings124

  • Version changed from 2.75 to 2.61

comment:23 Changed 5 years ago by x190

Re-open this ticket with full details, if you still have this issue with v2.84.

Note: See TracTickets for help on using tickets.