Opened 9 years ago

Closed 9 years ago

#5014 closed Bug (duplicate)

Should Transfer Completed from Incomplete Folder to Final Location in Background

Reported by: coneybeare Owned by: livings124
Priority: High Milestone: None Set
Component: Mac Client Version: 2.61
Severity: Major Keywords: ui freeze main thread
Cc:

Description

I have my Incomplete downloads folder located on an attached USB drive. I have my completed folder in another external firewire drive.

When a large movie is completed downloading, Transmission moves the file from one drive to the other as expected. The problem is that it does this on the main thread, locking the UI until the transfer is complete.

When both the incomplete and completed folders are on the same drive, this means just moving a pointer and is almost instantaneous. With more complicated setups however, this can take minutes of frozen UI to complete. I suggest making the move on a background thread, with UI updates that says something along the lines of "Moving file to folder..."

I am using 2.61 on a Mac Mini running 10.8.0

Change History (1)

comment:1 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This is covered by #1753.

Note: See TracTickets for help on using tickets.