Opened 9 years ago

Closed 9 years ago

#5029 closed Enhancement (duplicate)

Create .part files only with Piece size instead of whole file size

Reported by: joojoo Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.52
Severity: Normal Keywords: part.files, excessive.data
Cc:

Description

When a torrent contains multiple files and a user wants to download only some of those files, the client (in this case transmission-daemon) has to download some "overflow" data, depending on the Piece size. These "overflow" data then have to be stored on the disk.

As of now, they are stored in the new file to which these data belong to (usually the next file in the torrent filelist). However the allocated file has the full size, which may be very ineffective.

Example: The torrent has two files, 2049MiB in size, piece size is 4MiB. User wants to download only the first file. The client then has to download 2052MiB of data (i.e. 513 pieces), completes the first file and stores the excessive 3MiB in the second file - of size 2049MiB instead of 3MiB. The result is almost 2GiB of space wasted for 3MiB of data.

Changing preallocation option to 0 didn't seem to have influence on this behavior.

This also results in being unable to download all but one file from the torrent. The last file will always be present on the disk with full size because there's only a very small chance that other files will fit into previous pieces perfectly.

Proposed solutions: 1) the uTorrent way - create some arbitrary tmp.part file next to the download files to store excessive data. This .part file will only have size of the torrent piece. 2) After the download, discard the excesssive data.

Change History (1)

comment:1 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #532.

Note: See TracTickets for help on using tickets.