Opened 9 years ago

Closed 9 years ago

#5032 closed Bug (fixed)

gobject warning when updating blocklist from URL

Reported by: ewtoombs Owned by: jordan
Priority: Lowest Milestone: 2.82
Component: GTK+ Client Version: 2.61
Severity: Trivial Keywords: gobject, glib, gtk, blocklist, update, warning
Cc:

Description

I get this gobject warning from stdout/err when closing the preferences window in transmission-gtk after having manually updated the blocklist from a specified URL:

(transmission-gtk:1859): GLib-GObject-WARNING **: gsignal.c:2576: instance `0x1275530' has no handler with id `13262'

The id varies with each trial. The warning is reproducible. Here are the steps:

  1. open transmission-gtk on the command line, or else find some other means to capture its stdout/err.
  2. Goto preferences
  3. switch to Privacy tab
  4. update the blocklist
  5. close preferences window

It should be noted that I am running archlinux 64bit. These are the relevant package versions (I think. Ask for any others that might be important.)

  • gtk3-3.4.4-1
  • glib2-2.32.4-1

I don't program with GObject (in fact, I rather abhor it), so I don't really know if this is a big deal. Just thought I'd let you guys know about it.

Attachments (1)

transmissionbt.5032.diff (87 bytes) - added by fanatid 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by jordan

  • Status changed from new to assigned

Changed 9 years ago by fanatid

comment:2 Changed 9 years ago by fanatid

Signal blocklist_data.updateBlocklistTag is disconnected twice if update message dialog was created. First in onBlocklistUpdateResponse, and second in privacyPageDestroyed because variable blocklist_data.updateBlocklistTag hasn't installed to zero....

Need just add data->updateBlocklistTag = 0; after g_signal_handler_disconnect in onBlocklistUpdateResponse in file gtk/tr-prefs.c

comment:3 Changed 9 years ago by jordan

  • Milestone changed from None Set to 2.82

comment:4 Changed 9 years ago by jordan

Patched in r14144. Thanks :)

comment:5 Changed 9 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.