Opened 9 years ago

Closed 9 years ago

#5038 closed Bug (wontfix)

Mac slow to sleep when Transmission running

Reported by: phraktle Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.61
Severity: Normal Keywords:
Cc: phraktle@…

Description

Steps to reproduce

With transmission running:

  • pmset sleepnow
  • Power -> Sleep
  • Apple Menu -> Sleep
Expected
Immediate sleep
Actual
Sleep after a significant delay. Running pmset -g log contains the following line:
Time stamp                Domain              	Message                                                                    	Duration  	Delay     
==========                ======              	=======                                                                    	========  	=====     
9/12/12 1:04:25 AM GMT+0 SlowResponse        	Kernel: Response from Transmission is slow                                 	          	15001 ms  	

Change History (3)

comment:1 Changed 9 years ago by livings124

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:2 Changed 9 years ago by phraktle

  • Cc phraktle@… added

comment:3 Changed 9 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

This is by design. We stall sleeping for 15 seconds when there are active transfers so that they can be paused. If we didn't, they would be stopped without the trackers having any chance of being notified. There are clearly trade-offs here, but I think the delay is the better option.

Note: See TracTickets for help on using tickets.