Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5049 closed Bug (fixed)

Vuze can not connect to Transmission

Reported by: hsn Owned by: jordan
Priority: High Milestone: 2.70
Component: Transmission Version: 2.61
Severity: Major Keywords:
Cc:

Description

This is long standing bug in Vuze and Transmission. Currently i am testing it with transmission 2.61 and vuze 2.7.1.2.

Setup: both vuze and transmission are set to require encryption. Connection works only from Transmission -> Vuze. It never works in opposite direction Vuze -> Transmission.

Its easy to reproduce. Start Vuze and then select torrent with lot of peers. Let it run for a while, then click Torrent Details -> Clients -> And sort this column by client name. You will see in Vuze that All Transmission clients connected to torrent have flag 'R'. Connection initiated by remote. I never seen flag 'L' in Vuze against Transmission client.

If you look at vuze console, with tracking set to net & peers. it looks like initial handshake is never finished - it timeouts.

Change History (4)

comment:1 Changed 9 years ago by jordan

  • Milestone changed from None Set to 2.70
  • Owner set to jordan
  • Status changed from new to assigned

comment:2 Changed 9 years ago by jordan

How did this go for so long without being noticed... gahhh.

Fixed r13527.

comment:3 Changed 9 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 Changed 9 years ago by livings124

  • Priority changed from Normal to High
Note: See TracTickets for help on using tickets.