Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5062 closed Bug (duplicate)

Crash while seeding - OS X 10.8.2 & Transmission 2.71 (13542)

Reported by: needlestack Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.71
Severity: Normal Keywords:
Cc:

Description

I have four files that I have been seeding for many months - after updating to 2.71 Transmission will crash sporadically - usually within a few minutes of launching. I did not find the requested logs in Console.app, but I did put the crash report on pastebin:

http://pastebin.com/tZ1mty6E

After launching, I do see it pick up peers and actually perform some seeding, so it doesn't crash as soon as someone connects. If I pause all but one torrent, it still crashes, even if I've seen that torrent successfully seed for a few minutes.

Let me know if there's any other testing you'd like me to do.

Change History (4)

comment:2 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This does appear to be a duplicate of #5002

comment:3 follow-up: Changed 9 years ago by cfpp2p

opps, sorry looks like livings124 & x190 are already on this...

3   libsystem_c.dylib                   0x00007fff9710dd17 __stack_chk_fail + 195
4   org.m0k.transmission                0x00000001000c52d6 UTPSocket::selective_ack(unsigned int, unsigned char const*, unsigned char) + 724
5   ???                                 0x0000e3a30000e3a4 0 + 250289219232676

needlestack -

Let me know if there's any other testing you'd like me to do.

Do you still get crashes if uTP is turned off?

Last edited 9 years ago by cfpp2p (previous) (diff)

comment:4 in reply to: ↑ 3 Changed 9 years ago by needlestack

Replying to cfpp2p:

Do you still get crashes if uTP is turned off?

I would test that for you - but unfortunately (fortunately?) it hasn't crashed in the past few hours. I did a reboot at some point in there, and it hasn't crashed since. If it starts crashing again I will try this. Otherwise, as much as I hate to admit it, I guess I should try rebooting before submitting a bug report :)

Also got to say Transmission is one of the most polished pieces of free software that I use regularly. Great job all.

Note: See TracTickets for help on using tickets.