Opened 9 years ago

Closed 9 years ago

#5068 closed Bug (duplicate)

Setting cache-size-mb to a high value (e.g. 64) on tramsission-daemon causes "Bad file descriptor" and "Piece # is corrupt. Verify local data."

Reported by: karamanolev Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.71
Severity: Normal Keywords: memory
Cc:

Description

Because I didn't understand what exactly "cache-size-mb" does, I set it to 64 on my transmission-daemon. This caused sporadic "Bad file descriptor" and "Piece # is corrupt" errors. I'm not sure why these errors happen when the cache size is so big, but probably they shouldn't. If there's an inherent limit, then transmission-daemon should give the correct error message. If not, then it shouldn't fail in that way. I had to debug on 3 different machines, including VMs, to figure out what the problem is.

Change History (1)

comment:1 Changed 9 years ago by karamanolev

  • Resolution set to duplicate
  • Status changed from new to closed

It turns out that reducing cache size only made it not-show for a certain period of time. It's happening again. It's a duplicate of another bug, https://trac.transmissionbt.com/ticket/4147

[14:15:10.566] {sometorrent} write failed for "{somefile}": Bad file descriptor (inout.c:132) [14:15:10.566] {sometorrent} Bad file descriptor ({somefile}) (torrent.c:486)

Note: See TracTickets for help on using tickets.