Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5091 closed Bug (fixed)

Disable file selection for non-multi-file transfers

Reported by: livings124 Owned by: jordan
Priority: Normal Milestone: 2.72
Component: Web Client Version: 2.71
Severity: Minor Keywords:
Cc:

Description

There shouldn't be an option to deselect the file for a single-file torrent (although for consistency, I personally don't think it's a big deal to be able to deselect a multi-file transfer file with a single file).

Change History (7)

comment:1 Changed 9 years ago by jordan

  • Milestone changed from None Set to 2.72
  • Owner set to jordan
  • Severity changed from Normal to Minor
  • Status changed from new to assigned

comment:2 Changed 9 years ago by jordan

Fixed r13575

comment:3 Changed 9 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 Changed 9 years ago by kontrol

An unintended consequence of this change is difficulty being able to partial seed files. Previously I could verify local data with all files unchecked and immediately begin seeding data. Now I must use transmission-remote to set the files to not download (-G or --no-get) or set the download speed to 0 kB/s (-d or --downlimit) to prevent the torrent from downloading unwanted data.

Setting all files to not download now leads to "Announce error: Invalid event= from client.", so limiting download speed to 0 Kb/s appears to be the sanest workaround, but will lead to cluttering up the Show Downloads filter.

comment:5 Changed 9 years ago by livings124

I don't think seeding partial files is a use case most people will have.

comment:6 Changed 9 years ago by kontrol

I also cannot properly deselect files in multi-file torrents. If I un-check anything it results in only the bottommost file/folder being deselected. However, I can still achieve the expected behavior using tansmission-remote.

comment:7 Changed 9 years ago by livings124

That bug's fixed in #5108.

Note: See TracTickets for help on using tickets.