Opened 9 years ago

Closed 9 years ago

#5105 closed Bug (fixed)

Adding magnets to minimized window crashes.

Reported by: Ram-Z Owned by: jordan
Priority: Normal Milestone: 2.80
Component: Qt Client Version: 2.72
Severity: Normal Keywords:
Cc:

Description

When adding a magnet to transmission-qt while it is minimized to tray the application quits.

Chakra x86_64 transmission-qt 2.72 (13582)

Change History (9)

comment:1 Changed 9 years ago by livings124

  • Component changed from Transmission to Qt Client
  • Owner set to jordan

comment:2 Changed 9 years ago by jordan

Ram-Z, what platform is this occurring on? Is it possible for you to get a crash trace showing where in the code the crash occurred?

comment:3 Changed 9 years ago by Ram-Z

Platform: Chakra Linux x86_64, KDE

Running it from console yields no messages, gdb returns

[New Thread 0x7fffe7736700 (LWP 14724)]
[New Thread 0x7fffe6f35700 (LWP 14725)]
[New Thread 0x7fffe6734700 (LWP 14726)]
[New Thread 0x7fffe5c2b700 (LWP 14729)]
[Thread 0x7fffe5c2b700 (LWP 14729) exited]
[Thread 0x7fffe6f35700 (LWP 14725) exited]
[Thread 0x7fffe7736700 (LWP 14724) exited]
[Thread 0x7fffe6734700 (LWP 14726) exited]
[Inferior 1 (process 14721) exited normally]

Not much to go with. I'd be happy to provide you with any information you need.

comment:4 Changed 9 years ago by jordan

I'm not able to reproduce this issue. Could you walk me through the exact steps to make this crash happen? Is it still happening for you in in 2.75?

comment:5 Changed 9 years ago by Ram-Z

  • Version changed from 2.72 to 2.75

I'll even show it to you, I recommend downloading the video, the quality in Dropbox' web player is pretty bad: https://www.dropbox.com/s/ee0lxsbpp27oz7i/transmission.mp4

I'll be on #transmission for a while, if you need more info. Nick is either Ram-Z or ramsi.

comment:6 Changed 9 years ago by jordan

  • Version changed from 2.75 to 2.72

comment:7 Changed 9 years ago by jordan

Thanks for the video! I'm now able to see this in 2.75.

One interesting thing is that I'm NOT seeing this in trunk. If you're comfortable with building from source, could you give svn trunk (or one of the nightly tarballs at build.transmissionbt.com) a try?

comment:8 Changed 9 years ago by Ram-Z

I can't reproduce it in trunk either.

comment:9 Changed 9 years ago by jordan

  • Milestone changed from None Set to 2.80
  • Resolution set to fixed
  • Status changed from new to closed

By a happy coincidence, it looks like this was fixed as a side-effect of r13733 for #5206.

Note: See TracTickets for help on using tickets.