Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5107 closed Bug (invalid)

Filename issues on Synology NAS

Reported by: guidebook Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.73
Severity: Normal Keywords:
Cc:

Description

When adding a torrent with its files already downloaded, files with diacritic marks like é ou è (that are very common in French) are ignored by Transmission.

Precisely, "Verify local data" doesn't find those files and mark them with a progression of 0%. It seems there is a problem with the encoding used for the filenames.

This bug happened on a Synology DS210j.

Change History (4)

comment:1 Changed 10 years ago by rb07

This is not a problem with Transmission.

Transmission uses UTF-8 for all file names, that includes those with foreign characters, and it works fine in most operating systems (exceptions being Windows, which uses either ASCII or UTF-16; any operating system and file system configured like Windows, i.e. USB drives with FAT32 or NTFS where the file names don't correspond with the UTF-8 file name).

comment:2 Changed 10 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 follow-up: Changed 10 years ago by guidebook

The Synology Transmission package maintainer thinks the problem lies in Transmission code. Please see the ticket: https://github.com/SynoCommunity/spksrc/issues/268#issuecomment-9869769

comment:4 in reply to: ↑ 3 Changed 10 years ago by rb07

Replying to guidebook:

The Synology Transmission package maintainer thinks the problem lies in Transmission code. Please see the ticket: https://github.com/SynoCommunity/spksrc/issues/268#issuecomment-9869769

He "thinks" but he doesn't know, or tested.

I did test before posting my comment. I have a different NAS, but I don't think the problem is with your NAS.

I suggest you use the forum (not this issue tracker) to try figure out what the real problem is. It could be the .torrent file, it could be that you didn't download the files but somehow created the files on Windows (with UTF-16 file names), it could be many things...

Note: See TracTickets for help on using tickets.