Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#513 closed Bug (fixed)

Crash on trying to open first torrent file (Transmission compiled for Nokia 770, GTK 2.6.10)

Reported by: serge Owned by: charles
Priority: Normal Milestone: 0.95
Component: GTK+ Client Version: 0.94
Severity: Normal Keywords:
Cc:

Description

When trying to open the first torrent file, Transmission crashes with the following error message displayed in console:

transmission[4596]: GLIB ERROR default - file tr_torrent.c: line 141 (tr_torrent_stat): assertion failed: (TR_IS_TORRENT(tor))

Quick investigation shows that it comes here from 'formatname' function which gets invalid empty data (including 'gtor' pointer) after a call to:

gtk_tree_model_get( model, iter, MC_NAME, &name, MC_STAT, &status,

MC_ERR, &err, MC_SIZE, &size, MC_ETA, &eta, MC_PEERS, &tpeers, MC_UPEERS, &upeers, MC_DPEERS, &dpeers, MC_TORRENT, &gtor, -1 );

Apparently this is caused by 'tr_core_insert' function initially adding empty row and filling it with data a few code lines later (probably empty row attempts to get displayed somehow immediately after its addition). Using more atomic function 'gtk_list_store_insert_with_values' fixes this problem. A patch is attached.

Attachments (1)

torrent_open_crash_fix.diff (654 bytes) - added by serge 14 years ago.

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by serge

comment:1 Changed 14 years ago by serge

  • Component changed from Transmission to GTK+ Interface
  • Owner set to charles
  • Severity changed from Blocker to Normal

comment:2 Changed 14 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

committed in r4035. thanks for tracking it down and submitting the patch!

comment:3 Changed 14 years ago by charles

  • Milestone changed from None Set to 0.95
Note: See TracTickets for help on using tickets.