Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5134 closed Bug (fixed)

Magnet links not adding trackers with tr.0=

Reported by: moo Owned by: livings124
Priority: Normal Milestone: 2.74
Component: libtransmission Version: 2.72
Severity: Normal Keywords:
Cc:

Description

when using torrent file, i can get tracker in http/udp protocols in 1 torrent file. but when using magnet, only udp:// tracker address is avaiable

Change History (12)

comment:1 Changed 8 years ago by livings124

Are you sure the magnet link you're adding has both http and udp information in the link?

comment:2 Changed 8 years ago by livings124

I was successfully able to add a magnet link with two addresses, which were both the same except for http/udp.

comment:3 Changed 8 years ago by moo

the link is magnet:?xt=urn:btih:fdabf527f56deaa184f06bfc45760677b5f7a622&tr.0=http://tracker.ktxp.com:6868/announce&tr.1=udp://tracker.ktxp.com:6868/announce

you can see 2 address in the link. and i can see only 1 udp:// tracker in transmission. can you reproduce with this link?

comment:4 Changed 8 years ago by JJTagy

Looks like magnet forcing 0 and 1 is the issue. Try this: magnet:?xt=urn:btih:fdabf527f56deaa184f06bfc45760677b5f7a622&tr=http://tracker.ktxp.com:6868/announce&tr=udp://tracker.ktxp.com:6868/announce

comment:5 Changed 8 years ago by JJTagy

I assume it has to do with the recent changes to tracker 0 vs. tracker 1.

comment:6 Changed 8 years ago by livings124

  • Summary changed from got udp tracker only using magnet link to Magnet links not adding all trackers with tr.x=

Yup, it doesn't like the tr.0 part of the url. I'm not seeing the tr.x format in http://en.wikipedia.org/wiki/Magnet_URI_scheme#Address_tracker_.28tr.29. What is the tr.0/tr.1 representing?

comment:7 Changed 8 years ago by livings124

  • Component changed from Daemon to libtransmission
  • Owner set to jordan

comment:8 Changed 8 years ago by moo

regarding to "I'm not seeing the tr.x format in in wikipedia": there is an example "magnet:?xt.1=[ URN of the first file]&xt.2=[ URN of the second file]". i assume it's using "xt" for example while all key/value should support this notation when it comes to multiple value. and transmission supports multiple tr or "tr.1 + tr.2 + tr.3 etc" fine. just not tr.0. i'll bug the website to change url from tr.0&tr.1 to tr.1&tr.2, but it still nice to support tr.0

comment:9 Changed 8 years ago by livings124

Relevant: #3341

comment:10 Changed 8 years ago by livings124

  • Milestone changed from None Set to 2.80
  • Owner changed from jordan to livings124

comment:11 Changed 8 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Magnet links not adding all trackers with tr.x= to Magnet links not adding trackers with tr.0=

comment:12 Changed 8 years ago by jordan

  • Milestone changed from 2.80 to 2.74
Note: See TracTickets for help on using tickets.