Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5145 closed Bug (fixed)

[PATCH] fix a syntax error in transmission-qt.desktop

Reported by: kalev Owned by: jordan
Priority: Normal Milestone: 2.76
Component: Qt Client Version: 2.73
Severity: Normal Keywords:
Cc:

Description

desktop-file-validate complains:

transmission-qt.desktop: error: file contains key "_Name" in group "Desktop Action Minimize", but key names must contain only the characters A-Za-z0-9- (they may have a "[LOCALE]" postfix)
transmission-qt.desktop: error: required key "Name" in group "Desktop Action Minimize" is not present

This is caused by using key _Name instead of Name. Attaching a patch to fix this.

Looks like a copy-paste error from transmission-gtk.desktop: the -gtk desktop file needs to prefix these with _ to make the fields translatable.

Attachments (1)

transmission-2.72-desktop-file-validate.patch (367 bytes) - added by kalev 9 years ago.
Patch

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by kalev

Patch

comment:1 Changed 9 years ago by jordan

  • Milestone changed from None Set to 2.80
  • Status changed from new to assigned
  • Version changed from 2.73+ to 2.73

Fixed in r13723.

comment:2 Changed 9 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 9 years ago by jordan

  • Milestone changed from 2.80 to 2.76
Note: See TracTickets for help on using tickets.