Opened 9 years ago

Closed 9 years ago

#5150 closed Bug (fixed)

improper escaping of dirnames with new json?

Reported by: reardon Owned by: jordan
Priority: Normal Milestone:
Component: Transmission Version: 2.73+
Severity: Normal Keywords:
Cc:

Description

building against 13621, I am running into a problem with most handling of directory names over the RPC interface. It seems they are being improperly escaped, so '/home/user' becomes '\/home\/user' etc.

I am guessing this is due to new JSON code. Haven't had time to investigate.

To repro: use a THIRD-PARTY client, not transmission-remote, and attempt to set the default download-dir, or move an existing torrent to a new folder.

This is on Linux/Debian? (wheezy).

Change History (4)

comment:1 Changed 9 years ago by livings124

  • Version changed from 2.73 to 2.73+

comment:2 Changed 9 years ago by jordan

  • Milestone None Set deleted
  • Owner set to jordan
  • Status changed from new to assigned

comment:3 Changed 9 years ago by jordan

r13623 adds a regression test to trigger this bug and r13624 has the fix.

Thanks for reporting this!

comment:4 Changed 9 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.