Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5155 closed Bug (fixed)

Entering text moves selection point to end

Reported by: user967 Owned by: jordan
Priority: Normal Milestone: 2.76
Component: Qt Client Version: 2.73
Severity: Normal Keywords:
Cc:

Description

When typing text in the search box in transmission-qt, the cursor is moved to the end. It does not seem possible to insert or delete more than one character in the search, except for at the right end.

Attachments (1)

014-filterbar-textfield.diff (389 bytes) - added by rb07 8 years ago.
Fix. Left the deleted code in case this change breaks something else, seems fine after some testing.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by rb07

Confirmed. Thanks for the report.

Changed 8 years ago by rb07

Fix. Left the deleted code in case this change breaks something else, seems fine after some testing.

comment:2 Changed 8 years ago by user967

thanks, I am testing this on trunk now, and will add information if I notice any problem.

seems to work as expected so far though.

comment:3 Changed 8 years ago by jordan

I'm not looking at the code right now but IIRC that line that you're commenting out is to keep the UI in sync with the settings from the server. A better approach might be to update the field unless it's got focus (ie, the user's editing it).

rb07, do you want to try that approach & see if it's acceptable in your tests?

comment:4 Changed 8 years ago by rb07

jordan,

I don't understand your comment. What does the filter have to do with the server? or the settings?

We are talking about a filter on the torrent list view. Local or remote session has nothing to do with this.

comment:5 Changed 8 years ago by jordan

Ooop you are completely right, I was thinking this was about entries in the prefs dialog.

comment:6 Changed 8 years ago by jordan

  • Milestone changed from None Set to 2.80
  • Status changed from new to assigned

I've taken out the Prefs::FILTER_TEXT handling as per rb07's patch, WfM.

comment:7 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

Committed in r13706.

Last edited 8 years ago by jordan (previous) (diff)

comment:8 Changed 8 years ago by user967

  • Resolution fixed deleted
  • Status changed from closed to reopened

r13704 does not appear to be related to this ticket. filterbar.cc is unchanged in trunk since 08/01/11.

I am ignorant about this issue apart from what I reported. In particular, the purpose of the commented line in the proposed patch is not clear to me, but it seems worth mentioning that I noticed the same behavior in some other QT app's search box a few days ago, though I cant seem to reproduce it now. I wonder then, if this bug could be due to some change in QT, and if the old code may have some purpose for older QT.

comment:9 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from reopened to closed

I pasted the wrong revision number above; I meant r13706. I've fixed the comment in an edit :)

comment:10 Changed 8 years ago by user967

sorry for the trouble. my mistake, I was not viewing trunk after all.

thank you for qt client improvements and other optimizations in progress.

comment:11 Changed 8 years ago by jordan

  • Milestone changed from 2.80 to 2.76
Note: See TracTickets for help on using tickets.