Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5159 closed Bug (duplicate)

High CPU use on NAS or high speed internet

Reported by: Floris Owned by:
Priority: High Milestone: None Set
Component: Transmission Version: 2.72
Severity: Major Keywords:
Cc:

Description

CPU load stops transmission-gtk from working and sometimes even hinders other programs or freezes the PC. After some minutes, cpu load drops and transmission works again for some seconds.

Problems noticed after 2 events took place: 1 - changed my internet speed from 10 Mb/s down and 1 Mb/s up to 30 Mb down and 3 Mb up. 2 - moved the USB HDD to which transmission writes to my router to serve as NAS. Gb LAN Network should not be the problem though.

I have 3 torrents running. But even pausing all but 1 torrents still results in greyed out transmission window.

I tuned transmission using http://www.techsupportalert.com/content/optimizing-transmission-bittorrent-client-speed.htm#adjusting-transmission-internal-settings. This has no effect.

Gnome system monitor shows Transmission-gtk with 0 percent.

system: AMD A8 running Ubuntu 12.04 with gnome3 shell and Transmission (believe it was 2.51, anyway from repos) (later upgraded to 2.72, problem remains)

Change History (2)

comment:1 Changed 8 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for reporting this behavior.

If you're saving to a USB NAS drive, it's very likely that disk IO is blocking the transmission-gtk GUI from updating. There's a ticket open on this that you might be interested in, bug #1753.

Otherwise, I'm a little confused by this summary -- if gnome system monitor reports transmission-gtk using 0% of the CPU, why do you say that high CPU use is the issue?

I'm tentatively closing this ticket as a duplicate of #1753.

comment:2 Changed 8 years ago by Floris

Hi jordan,

As the Transmission window greys out on downloading while saving to NAS and other apps (openshot, but also gnome) also freezes while downloading I assumed this is due to high CPU use but you're right, the cause may be different. Further notes to the behaviour:

  • no freezes while merely uploading from NAS (but still when downloading, even with only 1 torrent)
  • the other apps do not use the NAS (both ubuntu and the openshot projects are on internal SSD)

If you give me some commands to log various CPU and disk I/O's, I'll send this log from a period of running transmission on an otherwise idle system. This might give better indication of the bug being duplicate. Determining my NAS speed might be helpfull as well, I'll see if I can find out how to do that (tips welcome)

I read hints of solutions in thread 1753, but can't figure out what I should do to solve this problem on my PC?

Note: See TracTickets for help on using tickets.