Opened 8 years ago

Closed 8 years ago

#5166 closed Bug (duplicate)

transmission-2.72 freezes on Fedora 18 x86_64

Reported by: belegdol Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.72
Severity: Normal Keywords:
Cc:

Description

Hi,

I upgraded to Fedora 18 yesterday and now transmission will freeze for me after several minutes of usage. Sometimes sooner though. gdb shows the following:

Program received signal SIGPIPE, Broken pipe.
[Switching to Thread 0x7fffe7fff700 (LWP 3161)]
0x0000003a5c6eb051 in __libc_writev (fd=<optimized out>, vector=<optimized out>, count=<optimized out>)
    at ../sysdeps/unix/sysv/linux/writev.c:55
55	      result = INLINE_SYSCALL (writev, 3, fd, CHECK_N (vector, count), count);
(gdb) bt
#0  0x0000003a5c6eb051 in __libc_writev (fd=<optimized out>, vector=<optimized out>, count=<optimized out>)
    at ../sysdeps/unix/sysv/linux/writev.c:55
#1  0x0000003a66e146bf in evbuffer_write_iovec (fd=47, howmuch=-1, howmuch@entry=393, buffer=<optimized out>, 
    buffer=<optimized out>) at buffer.c:2275
#2  0x0000003a66e17a95 in evbuffer_write_atmost (buffer=0x7fffdc32fbe0, fd=47, howmuch=393) at buffer.c:2359
#3  0x000000000044c206 in tr_evbuffer_write ()
#4  0x000000000044c3e6 in tr_peerIoTryWrite ()
#5  0x000000000044e1dd in tr_peerIoFlush ()
#6  0x000000000046c6ef in phaseOne ()
#7  0x000000000046cc04 in tr_bandwidthAllocate ()
#8  0x0000000000475dca in bandwidthPulse ()
#9  0x0000003a66e100e2 in event_process_active_single_queue (activeq=<optimized out>, base=<optimized out>) at event.c:1340
#10 event_process_active (base=<optimized out>) at event.c:1407
#11 event_base_loop (base=<optimized out>, flags=0) at event.c:1604
#12 0x0000000000462480 in libeventThreadFunc ()
#13 0x000000000044e27a in ThreadFunc ()
#14 0x0000003a5ca07d15 in start_thread (arg=0x7fffe7fff700) at pthread_create.c:308
#15 0x0000003a5c6f22cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Any ideas what is going on? Thank you for your help in advance.

Change History (1)

comment:1 Changed 8 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Hi belegdol, thanks for reporting this.

  1. the SIGPIPE error is a red herring that's not related to this problem (or any other Transmission problem). To avoid gdb stopping in SIGPIPE, use the folloing command in gdb: handle SIGPIPE nostop noprint pass
  1. The freeze is probably being caused by disk IO blocking the GUI thread, which is already ticketed in bug #1753.

I'm going to mark this as a duplicate. If you work with gdb some more and find that it's a different blocking issue, please do reopen this ticket with more information. Thanks!

Note: See TracTickets for help on using tickets.