Opened 8 years ago

Closed 8 years ago

#5167 closed Bug (invalid)

[PATCH] Fix bug affecting buttons to change torrent file get/priority.

Reported by: toehio Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.73
Severity: Normal Keywords:
Cc:

Description

In the file viewer pane, each file has buttons associated with it to change get or priority. The callbacks registered to the buttons were not in the right context, which meant they weren't accessing the correct object that contained the file ID, but another object with the same name in another scope (which happened to be an object describing the last file, left over from a temporary var that was used when populating/refreshing the file list).

This patch addresses the abovementioned problem by moving the callbacks' definition into another context.

Change History (2)

comment:1 Changed 8 years ago by livings124

I think the patch got lost somewhere. Could you reattach?

comment:2 Changed 8 years ago by toehio

  • Resolution set to invalid
  • Status changed from new to closed

Nevermind, this has been fixed on the trunk (but the problem is in the the 2.73 release).

Note: See TracTickets for help on using tickets.