Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5176 closed Bug (fixed)

Deselecting all remaining files not working correctly

Reported by: livings124 Owned by: jordan
Priority: Normal Milestone:
Component: libtransmission Version: 2.75+
Severity: Normal Keywords:
Cc:

Description

Deselecting all files in the inspector would previously switch a torrent to seeding immediately. This works correctly in 2.75, but not in r13681.

Change History (6)

comment:1 Changed 8 years ago by jordan

  • Status changed from new to assigned

comment:2 Changed 8 years ago by jordan

I bet it's because tr_torrentGetActivity() doesn't call tr_torrentRecheckCompleteness() anymore....

comment:3 Changed 8 years ago by jordan

livings124, does this resolve the problem for you?

Index: torrent.c
===================================================================
--- torrent.c	(revision 13670)
+++ torrent.c	(working copy)
@@ -2232,6 +2232,7 @@
 
     tr_torrentInitFileDLs (tor, files, fileCount, doDownload);
     tr_torrentSetDirty (tor);
+    tr_torrentRecheckCompleteness (tor);
     tr_peerMgrRebuildRequests (tor);
 
     tr_torrentUnlock (tor);

comment:4 Changed 8 years ago by livings124

jordan: that does the trick

comment:5 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r13682

comment:6 Changed 8 years ago by cfpp2p

this bug/regression was caused by the ill-fated r13651 & r13670

-tr_torrent_activity
-tr_torrentGetActivity (tr_torrent * tor)
-{
-    /* FIXME: is this call still needed? */
-    tr_torrentRecheckCompleteness (tor);
-
-    return torrentGetActivity (tor);
-}
-
+tr_torrent_activity
+tr_torrentGetActivity (const tr_torrent * tor)
...

at least now we know the answer to the FIXME.

Note: See TracTickets for help on using tickets.