Opened 8 years ago

Closed 8 years ago

#5200 closed Enhancement (fixed)

Rename tr_benc as tr_variant

Reported by: jordan Owned by: jordan
Priority: Normal Milestone: 2.80
Component: libtransmission Version: 2.75
Severity: Minor Keywords:
Cc:

Description

The tr_benc struct got its name because it was originally an in-memory represenatation of bencoded data.

However, libtransmission also uses it to deserialize/serialize data in the JSON format as well. However, it's not really tied to the benc data format. libtransmission also uses it when serializing / deserializing JSON-formatted data. It also supports data types that aren't native to benc, such as bools and floating-point numbers.

A better analogue is QVariant and, to a lesser extent, GVariant. If we rename tr_benc to tr_variant, that will better communicate the class' intent.

Change History (3)

comment:1 Changed 8 years ago by jordan

r13667: initial drop.

r13668: svn add variant.c

r13669: copyediting: indentation, whitespace

r13671: fix the Mac client's xcode file.

comment:2 Changed 8 years ago by jordan

  • Status changed from new to assigned

comment:3 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.