Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#523 closed Bug (duplicate)

crashes with -h or --help , and similarly with random command options.

Reported by: crf Owned by: tiennou
Priority: Normal Milestone: 1.00
Component: Transmission Version: 1.02+
Severity: Minor Keywords:
Cc:

Description

If I run Transmission from the command-line with the -h or --help option it crashes. It also crashes with any random option like --whatever. The -p and -q options work though.

The man page for Transmission lists its options -->

-h --help

Print command-line option descriptions.

-p --paused

Start with all torrents paused

-q --quit

Quit a running transmission instance

Attachments (2)

core.tar.gz (218.1 KB) - added by crf 15 years ago.
core dump file
Transmission.TerminalCrashText.log (5.4 KB) - added by crf 15 years ago.
this is what's printed in the terminal when I try to run transmission with odd options

Download all attachments as: .zip

Change History (7)

comment:1 Changed 15 years ago by tiennou

  • Owner set to tiennou

comment:2 Changed 15 years ago by crf

  • Version changed from 0.95 to 0.95+

the -h and --help options now work properly, and no longer crash the program. But random fake options do still crash the program.

comment:3 Changed 15 years ago by tiennou

  • Status changed from new to assigned

If you could attach a crashlog for this. I'll be glad, because I can't get it to happen here.

Changed 15 years ago by crf

core dump file

Changed 15 years ago by crf

this is what's printed in the terminal when I try to run transmission with odd options

comment:4 Changed 14 years ago by crf

  • Resolution set to duplicate
  • Status changed from assigned to closed

This is a duplicate of bug #560, which has been fixed.

comment:5 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.00
Note: See TracTickets for help on using tickets.