Opened 8 years ago

Closed 8 years ago

#5272 closed Bug (fixed)

compilation error: "passing argument 1 of ‘quotactl’ makes pointer from integer"

Reported by: mechanic Owned by: jordan
Priority: Normal Milestone:
Component: libtransmission Version:
Severity: Normal Keywords:
Cc: taem@…

Description

I no long can compile the daemon on OS X. These are the options I have been using to compile: --enable-cli --enable-daemon --without-gtk --disable-mac. svn version r13949

platform.c: In function ‘getquota’:
platform.c:840: warning: passing argument 1 of ‘quotactl’ makes pointer from integer without a cast
platform.c:840: warning: passing argument 2 of ‘quotactl’ makes integer from pointer without a cast
platform.c:864:40: error: macro "btodb" requires 2 arguments, but only 1 given
platform.c:864: error: ‘btodb’ undeclared (first use in this function)
platform.c:864: error: (Each undeclared identifier is reported only once
platform.c:864: error: for each function it appears in.)

Attachments (2)

00-fix-compilation-on-osx-spaam.patch (508 bytes) - added by spaam 8 years ago.
00-fix-compilation-on-osx-spaam-v2.patch (354 bytes) - added by spaam 8 years ago.
fix compilation on osx spaam v2

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by jordan

  • Cc taem@… added

comment:2 Changed 8 years ago by jordan

taem, looks like this is in the quota code, can you take a look at it?

Last edited 8 years ago by jordan (previous) (diff)

comment:3 Changed 8 years ago by jordan

  • Summary changed from compilation error to compilation error: "passing argument 1 of ‘quotactl’ makes pointer from integer"

Changed 8 years ago by spaam

Changed 8 years ago by spaam

fix compilation on osx spaam v2

comment:4 Changed 8 years ago by spaam

Here is a patch for this problem

comment:5 Changed 8 years ago by spaam

use: 00-fix-compilation-on-osx-spaam-v2.patch better fix for this problem.

comment:6 Changed 8 years ago by taem

jordan, I guess spaam's patch fixed build error :)

comment:7 Changed 8 years ago by spaam

the problem is that SYS_DARWIN was only set if you are using xcode.

comment:8 Changed 8 years ago by jordan

  • Milestone None Set deleted
  • Status changed from new to assigned
  • Version 2.76+ deleted

comment:9 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

r13976: #5272 'quotactl breaks compilation of libT/platform.c on non-Xcode OS/X builds' -- fixed with patch from spaam

Note: See TracTickets for help on using tickets.