Opened 8 years ago

Closed 8 years ago

#5277 closed Bug (fixed)

Queue operation stopped working

Reported by: rb07 Owned by: jordan
Priority: Normal Milestone:
Component: Qt Client Version:
Severity: Normal Keywords:
Cc:

Description

As reported in Tr-Qt for Windows's forum https://sourceforge.net/p/trqtw/discussion/general/thread/b2306cad/?limit=25#b0e8:

In version 2.76 the context menu operations on the queue stopped working.

Yet another quark introduced bug... in session.cc:579 we have:

void Session :: queueMoveTop     (const QSet<int>& ids) { sendTorrentRequest ("torrent-move-top",    ids); } 
void Session :: queueMoveUp      (const QSet<int>& ids) { sendTorrentRequest ("torrent-move-up",     ids); } 
void Session :: queueMoveDown    (const QSet<int>& ids) { sendTorrentRequest ("torrent-move-down",   ids); } 
void Session :: queueMoveBottom  (const QSet<int>& ids) { sendTorrentRequest ("torrent-move-bottom", ids); } 

but in quark.h there is

  TR_KEY_queue_move_bottom,
  TR_KEY_queue_move_down,
  TR_KEY_queue_move_top,
  TR_KEY_queue_move_up,

and in and quark.c

  { "queue-move-bottom", 17 },
  { "queue-move-down", 15 },
  { "queue-move-top", 14 },
  { "queue-move-up", 13 },

so the old keys don't work anymore.

Change History (3)

comment:1 Changed 8 years ago by jordan

  • Milestone None Set deleted
  • Status changed from new to assigned
  • Version 2.76 deleted

Looks like this is a regression in the nightlies, rather than in a released version?

2.76 doesn't have quarks.

comment:2 Changed 8 years ago by rb07

Then the problem is that I don't use the 2.7x branch, I release from HEAD (using the revision number).

comment:3 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r13981. Thanks for reporting this.

Note: See TracTickets for help on using tickets.