Opened 8 years ago

Closed 8 years ago

#5288 closed Bug (duplicate)

Transmission crash in Max OS X Mountain Lion

Reported by: DaveGomez Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.76
Severity: Critical Keywords: Crash, OS X, Mac, Mountain Lion
Cc:

Description

Everytime I use transmission for the first time after turn on my laptop I can't pause a torrent or close the application without getting transmission crashed.

Sometimes it happens even after the first execution, two or three times after.

This is the error inform created by the application for Apple after the last crash.

http://pastebin.com/S3gwikmr

Change History (9)

comment:1 Changed 8 years ago by jordan

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:2 Changed 8 years ago by livings124

Can you post a crash log from a build from https://build.transmissionbt.com/job/trunk-mac/?

comment:3 Changed 8 years ago by DaveGomez

Sure, I will install this version. But I need you to tell me how to get the crash log, or are you talking about the same one generated by Mac OS X?

comment:4 Changed 8 years ago by DaveGomez

More news here.

The las version of Transmission published in the truck website you gave me can't even start.

Here's the crash log. http://pastebin.com/iVZS4YaZ

comment:5 Changed 8 years ago by livings124

What language is your system set to? Do you have a transfer selected when it crashes?

Last edited 8 years ago by livings124 (previous) (diff)

comment:6 Changed 8 years ago by DaveGomez

My system language is Spanish.

The crash occurs when I try to pause a torrent download or close the application the first time after I turn on my MacBook? (so yes, most of the times there's a download item selected). Then I have to force the application closing and start it again.

comment:7 Changed 8 years ago by livings124

The nightlies are going to crash in non-English mode for the time being, unfortunately. Would it be possible to set your language to English and replicate the crash with the nightlies?

comment:8 Changed 8 years ago by DaveGomez

Ok, I could recreate the crash using English as my system language. But this time, it didn't crash when I was trying to pause a torrent or close the application, but when I was trying to resume the paused torrent.

Here is the log --> http://pastebin.com/apD51Xmi

comment:9 Changed 8 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This hang appears to be an issue that would need to be solved by #1753. I'm going to mark this as a duplicate of that. Thanks for helping debug this; unfortunately there's not an easy fix.

Note: See TracTickets for help on using tickets.